IRC channel logs

2023-06-17.log

back to list of logs

<rlb>...*almost* finished rewriting everything (including all of strings.c) to eliminate wide-related code. After that the plan is to add the sparse utf-8 offset index, and then start cleaning up for review. (Though that could still take a while.)
<rlb>(I already have the sparse index code in another branch, just trying to build this one incrementally, for review.)
<cobra>hi, im using the web modules, and trying to (build-response) with header `((content-type (image/jpeg))) gives an error saying that image/jpeg is a bad value for the content-type header
<cobra>is this a limitation of guile's built-in web? or is there something i'm doing wrong
<rekado>use `((content-type . (image/jpeg)))
<cobra>thanks!
<spk121>setting GC_MARKERS=1 works around "unexpected stack mark overflow" bug in threads on Guile MinGW. the webserver test passes! Finally, a decent clue
<rekado>the broken pipe problem seems to have gone away when wrapping http-write in (uninstall-suspendable-ports!)…(install-suspendable-ports!)
<spk121>if it set env GUILE_JIT_LOG=1 and see output, does that mean JIT is working?
<sarna>is there a way to get tab completion and/or arrow keys to work in the repl? preferably without setting a guile alias that wraps it with readline
<rlb> https://www.gnu.org/software/guile/manual/html_node/Readline.html
<sarna>ah! darn, I missed it. thank you :)
<rlb>certainly
<rlb>Just spent too long tracking down an issue caused by the fact that some of the code is still using string_set_x (when it shouldn't/won't eventually), that stringbuf bytes are initially undefined, and that and my interim string_set_x was being too clever, as a result requiring the existing chars to be valid...
<rlb>On the plus side, it's been nice (with a terminal set to utf-8) to be able to use fprintf %lc and %*s to provide some fairly clear, very low level debugging output for the new code.