IRC channel logs

2023-06-09.log

back to list of logs

<rlb>wingo: perfect, and thanks. I'm assuming there's a "major" version number I'll need to find/work-with to make sure we reject incompatible go files (i.e. "major version bump") -- or maybe that's just the norm for Y releases? Planning to poke around for that later.
<wingo>rlb: a .go file made with guile X.Y.Z is placed in a directory specific to X.Y and will run only on X.Y.W where W >= Z
<rlb>wingo: oh, uh..., of course. I should have remembered that from the packaging. Thanks.
<mirai>For the simple task of checking whether a list only contains #f, are these approaches acceptable <https://paste.centos.org/view/06f07173> or am I missing a much simpler solution here?
<civodul>mirai: in general just use filter-map
<mirai>the result would be equivalent here, though why filter-map instead of filter?
<RhodiumToad>mirai: what result do you want for an empty list?
<mirai>the empty list is never encountered
<RhodiumToad>(every not '(...))
<mirai>lst is always non-empty (b. would fail if it was empty)
<mirai>oh, I didn't notice "not" was a procedure
<mirai>thought it was special like "if", "and" & co.
<mirai>thanks
<RhodiumToad>no reason it should be, it doesn't require delayed evaluation or multiple arities
<spk121>sneek: later tell civodul in your gc-benchmarks commit, gc-benchmarks/local.mk should "EXTRA_DIST +=" not "EXTRA_DIST ="
<sneek>Will do.
<spk121>sneek: are you working?
<RhodiumToad>sneek: botsnack
<sneek>:)
<spk121>civodul: In your gc-benchmarks commit, gc-benchmarks/local.mk should be "EXTRA_DIST +=" not "EXTRA_DIST ="
<RhodiumToad>iirc, "later tell" looks for when the specified nick next speaks, not when it joins
<spk121>oh, ok, makes sense