IRC channel logs

2023-05-31.log

back to list of logs

<dcunit3d>geiser keeps adding a project directory to the %load-path for guile. the project modifies the `geiser-guile-load-path` using setq-local. i'm trying to clear out my desktop locals, but i think it's cached somewhere else. the project has open buffers in emacs, but i'm not really interacting with them. other projects don't seem to do the same thing
<dcunit3d>i think i've got it
<dcunit3d>does geiser pack the current load path into the scheme *.go file?
<flatwhatson>dcunit3d: geiser adds its plugin to %load-path, and will add the project root if geiser-repl-add-project-paths is true
<flatwhatson>load-path isn't stored .go files, unless your scheme code is doing that explicitly
<daviid>dcunit3d: fwiw, to get rid of this 'project' annoyance (afaic), in my .emacs i do - (require 'project)\n(defun project-root (p) nil) - recommended by the geiser author at the time i asked
<flatwhatson>you can just (setq geiser-repl-add-project-paths nil)
<flatwhatson>your recommendation will break all other project.el functionality
<daviid>flatwhatson: when i asked for help, there was a bug in emacs and this emacs 'project' thing, the only way to get rid of ... was the above, i kept that since ...
<daviid>right, and ok, this project thing is a total nuisance afaic, but thanks for pointing this, for those who would want to use its functionality 'outside' guile/geiser ...
<flatwhatson>projects are useful! project-find-file is a basic use-case
<flatwhatson>the problem is geiser is half-in on projects by default. it uses one repl for all guile projects (unless you set geiser-repl-per-project-p), so ends up setting load-path for the first project but not others
<daviid>but i do not want geiser to ever touch my %load-path :) - anyway, let's hack - i just wanted to help those who wish to silent this annoying thing, done, feel free to use it if it helps you ofc
<dcunit3d>here's what i was seeing https://0x0.st/Hbqg.txt
<dcunit3d>it's been confusing but i think i understand
<dcunit3d>oh ok, i've been managing project load paths manually or with .dir-locals.el
<dcunit3d>thanks guys
<flatwhatson>that's fine, just geiser's automatic management might confuse. it's probably the reason "ellipsis" is twice on your load-path
<chrislck>sneek: botsnack
<sneek>:)
<mekeor>hello. when loading a module, is it possible to tell guile to not compile it, but instead use the built .go file, even if the .scm file is has a more recent timestamp?
<wingo>load-compiled on the .go file directly
<dokma>Finally got serious about reading the guile manual.
<dokma>Reaping the benefits already.
<dokma>Any jobs out there for Guile?
<dthompson>I don't know of any open positions but a few of us do get paid to write guile
<dokma>dthompson: some companies or gnu?
<dokma>
<dthompson>companies/non-profits.
<dthompson>gnu doesn't pay anyone.
<mister_m>I installed guile via guix (first time using it) and I am seeing a warning when starting the REPL: guile: warning: failed to install locale -- whta does this mean/refer to?
<jpoiret>mister_m: that's a guix thing, but basically you'll need to also install glibc-locales and set GUIX_LOCPATH=$HOME/.guix-profile/share/locale
<mister_m>is there some kind of setup guide for guix that I missed? I am not using bash so I could not have the guix installer modify my bash profile which probably is what would have configured these things
<mister_m>but thanks, I will look into that
<jpoiret>mister_m: I believe https://guix.gnu.org/en/manual/devel/en/guix.html#Locales-1 is what you're looking for
<mister_m>That removed the warning - appreciate it
<Aurora_v_kosmose>Does Goblins accommodate non-clearnet transports/proxies?
<dthompson>Aurora_v_kosmose: the networking layer is generic so it can be configured for any transport
<Aurora_v_kosmose>Oh, that's nice.
<dthompson>right now the only official thing is tor onion services.
<Aurora_v_kosmose>A good start. I was thinking of I2P and wondering how complicated it'd be to retrofit, but generic layers are wonderful.
<dthompson>the hope is to provide lots of useful options
<Aurora_v_kosmose>I'll have to keep an eye on it.
<dthompson>please do :)
<Aurora_v_kosmose>I'll also have to re-read its docs & presentation alongside SecuShare to make up my mind in any real way. It looks more promising than Gnunet so far.
<Aurora_v_kosmose>Though it's not a complete overlap in purposes either.
<Aurora_v_kosmose>(The application development parts though seem more well-thought out.)
<Aurora_v_kosmose>Making the primary routers & programs in C was one decision which I think limited its potential growth, as it adds an entirely unnecessary burden onto all users and makes securing the implementation much more complicated. This is incidentally the very same criticism I have for I2PD.
<Aurora_v_kosmose>I'm also happy to see info manuals along the source package for Goblins.
<mister_m>I've installed Haunt via guix. How can I get documentation/eldoc going in geiser?
<mekeor>mister_m: see (info "(geiser) Autodoc and friends") which instructs to type 'C-c C-d d' to show more docs...
<sneek>old: Greetings!!
<dokma>Is this a bug?
<dokma>vlatko@david /tmp % ./test.scm
<dokma>error: unrecognized switch -e main
<dokma>
<dokma>But in guile --help
<dokma> -e FUNCTION after reading script, apply FUNCTION to
<dokma> command line arguments
<dokma>
<dokma>Shebang in test.scm is:
<dokma>#!/usr/local/bin/guile -e main
<dokma>!#
<dokma>
<dokma>Nevermind... manual first gave a wrong example without warning ahead
<jpoiret>dokma: you need to use #!/usr/bin/env -S guile -e main instead
<dokma>#!/usr/local/bin/guile \
<dokma>-e main -s
<dokma>!#
<dokma>
<dokma>jpoiret: ^^^ this worked for me
<dokma> https://www.gnu.org/software/guile/manual/guile.html#The-Meta-Switch
<Arsen>some also just invoke a shell that execs guile
<dokma>The first, wrong, example threw me off path because the manual doesn't warn you that they are giving you a wrong example
<dokma>Has anyone used any sort of dynamic code generation in guile?
<mwette>dokma: you mean like (eval-string (sfstr "(quote `(~A ,~S))" name type)
<dokma>mwette: or more complex. Things that can give some suggestions to questions like: "How do I improve this trading algorithm?"
<mwette>try search for paper "A unified approach to solving seven programming problems", problem 4. where mkanren is used to find expressions which return 42 if lexically scoped or 137 if dynanically scoped.