IRC channel logs

2023-05-23.log

back to list of logs

<flatwhatson>RhodiumToad: because build systems are a pita that hardly anybody wants to invest more than the bare minimum to achieve their immediate goal and move on with their life. the only people who *really* care are the packaging folk dealing with the consequences.
<flatwhatson>when the proper solution looks like a hack to the untrained eye, a bad solution hack feels more acceptable; "can't be worse than that giant pile of shell hacks". of course, it can, and often is.
<flatwhatson>i think more modern high-level build systems help. when you can get an entire project built, tested & packaged correctly with a bare-minimum of configuration, you get less people trying their hand at inventing solutions to solved problems.
<flatwhatson>but we don't really have a good one of those for guile packages. hall is close, but not close enough imo (with all respect). the necessary time investment in this area is hard to come by because of my first point.
<old>I've made my own build system purely in guile because I was tired of the autoconf none-sens: https://git.sr.ht/~old/libpatch/tree/master/item/configure
<old>even though it does a lot of stuff. It's when you try to implement a generic build system that you realize that autotools is actually clever
<old>I'm happy with my build system in guile though since I can tweak to my exact needs
<chomwitt>hi. trying a hello world script i see ./hello-guile.scm: line 2: !#: command not found
<rlb>chomwitt: would need to know more to help. Does your script start with the preamble in "The Meta Switch" section in the info pages (4.3.2), or something else?
<rlb>Does anyone know if the fact that define-modules #:hide (x) conflicts with #:select ((x . y)) is intentional, or possibly an oversight?
<rlb>i.e. I don't want x to exist in the module as x, but I *do* want it to exist as y.
<chomwitt>I copied the script from info guile manual 2.2 Running Guile Scripts . Also my distro is Guix
<rlb>With 3.0.9, hide hides x from the rename, and so it fails.
<chomwitt>so there is no /usr/local/bin/guile and i changed it to #!/home/username/.guix-profile/bin/guile -s
<rlb>And the second line is just !#?
<rlb>(...and perhaps double check that /home/username/.guix-profile/bin/guile runs fine by itself, from the command line, if you haven't.)
<chomwitt>rlb, yes. !# . and double checked. guile runs by it self ok
<chomwitt>i wonder if using guix's home configure breaks the enviroment in some ways..
<rlb>That's an odd error. Offhand, I'd have guessed something a bit off in the file, i.e. delimiters, extra spaces or something. But the main question is why is it trying to run !# as a command -- if guile's interpreting the file via -s, it shouldn't be.
<rlb>(I've also occasionally seen misleading errors from ld.so when there's a problem with the #! interpreter...)
<chomwitt>ill double check for hidden char due to copy paste from info manual
<rlb>Could also try just retyping that from scratch in your favorite editor -- see if it makes any difference.
<rlb>i.e. in a new file
<chomwitt>ok
<chomwitt>ok
<chomwitt>typing it all by hand works
<chomwitt>so copy paste may carried hidden chars with it
<chomwitt>thanks for the tip
<rlb>Certainly, glad you got it working.
<RhodiumToad>flatwhatson: fwiw in this context "the packaging folk dealing with the consequences" is me
<apteryx>how can I read the stderr of a remote pipe when using Guile-SSH?
<sneek>Welcome back apteryx, you have 2 messages!
<sneek>apteryx, muradm says: could you have change to look at 63198? while it is closed, it has patch within. should i send it separately to have dedicated issue for it?
<sneek>apteryx, muradm says: there is also another one related to PAM but with screen-locker-service-type #63652.
<apteryx>ah, I think (channel-set-stream! my-channel 'stderr)
<apteryx>then (get-string-all my-channel) should return stderr, I believe.
<apteryx>yes, that works
<civodul>comrades, a puzzle: why's the heap reported by /proc/PID/smaps typically 10x that repoted by 'gc-stats'?
<civodul>that it's bigger is expected, but 10x?
<janneke>ACTION guesses: cells vs bytes?
<civodul>no no, GC_get_heap_size (used by gc-stats) returns the size of the GC-managed heap in bytes
<civodul>but the GC-managed heap is a subset of the total heap
<civodul>(i should mention i don't know the answer :-))
<civodul>ah well, 'total-heap-size' in gc-benchmarks/gc-profile.scm includes private mappings (so all the .go files)
<apteryx>how can 'guild compile' tell me about unused modules?
<civodul>apteryx: -Wunused-module, in current "main"
<apteryx>ah! unreleased yet I see, thanks :-)
<apteryx>is -Wall a thing?
<civodul>yup!
<civodul>or is it?
<civodul>-Wunused-module has false positives, though
<apteryx>-Wall is not a thing in 3.0.9 at least
<rlb>(Ignore my earlier question about #:select/#:hide - reworked things into a small test program, and I suspect I misunderstood.)
<mwette>I always add #:select when useing (srfi srfi-1) due to many potential dup's. Also, glad to see #:hide which I will now use on `filter' for (sxml match).
<sneek>Welcome back old :)
<old>sneek: botsnack
<sneek>:)
<cow_2001>old: lookit here. just a few dumb exercise solutions. https://git.sr.ht/~kakafarm/eopl3/tree/master/item/a.org
<old>I see someone has discovered the power of org-mode :-p