IRC channel logs

2023-03-20.log

back to list of logs

<daviid>lloda: guile-cairo 'make distcheck' pass now - i had a hard time, but finally got it right ... so i'll prepare a series of patches, send an email and will ping you to double check, push and try a make distcheck on your machine ...
<butingtaon>Hello everyone, i was trying to install guile-reader on debian 11 from the tarball on https://git.savannah.gnu.org/cgit/guile-reader.git/ but when i tried generationg ./configure using autoconf, i keep getting
<butingtaon>
<butingtaon>"configure.ac:9: error: possibly undefined macro: AM_INIT_AUTOMAKE
<butingtaon> If this token and others are legitimate, please use m4_pattern_allow.
<butingtaon> See the Autoconf documentation."
<butingtaon>oh that multiline message didnt send how i intended it to, i'm sorry about that
<butingtaon>anyways, any help is appreciated, thank you so much in advance
<butingtaon>Looks like running `autoreconf --install --force` is the way to go here
<butingtaon>although now autoreconf is complaining that it cant find 'build-aux/config.rpath'
<butingtaon>based on this github issue https://github.com/SSSD/ding-libs/issues/8 doing "touch 'build-aux/config.rpath'" does the trick.
<lloda>winter: at run time, but only once. It's a safety in case the argument is used more than once in the macro body
<winter>lloda: why would that be an issue/undesirable?
<winter>why would using just x be an issue? it's one argument all the same, no?
<lloda>the argument could be something like (apply f args), so if you use it multiple times, you are calling f multiple times
<lloda>ultimately it depends on what the macro is meant to do, but a lot of the time, one evaluation is what you want
<winter>ahhh, right, since this is just token pasting in the end
<winter>thank you
<lloda>👍
<mirai>Is there a better/conciser way to write (lambda (x y) (foo x (bar y))) ?
<mirai>I think cut/cute from SRFI-26 doesn't apply here
<drakonis>make a macro, i suppose?
<pinoaffe>mirai: you can do (compose (cut foo x <>) bar)
<pinoaffe>whoops, nope
<lloda>you don't need a macro for that unless if foo/bar aren't themselves macros
<lloda>s/unless if/if
<lloda>i mean compose is a normal function
<pinoaffe>mirai: you can do something along the lines of https://bpa.st/USC6I
<pinoaffe>mirai: or something like https://bpa.st/64K3W
<mirai>interesting
<sneek>wb dsmith :D
<dsmith>sneek, botsnack
<sneek>:)
<dsmith>!uptime
<sneek>I've been running for 2 days
<sneek>This system has been up 2 days, 17 hours, 53 minutes
<haugh>Does anyone have an example of working with guile-json and the GNU extension to SRFI-9? I really love both the JSON mapping features of the former (especially the nested record recognition) and the functional setters of the latter, but they don't seem compatible, especially since guile-json is built on mutable records.
<haugh>Right now it looks like I'll be maintaining a separate conversion layer between JSON records and functional records and I'm not sure how to manage it.
<count3rmeasure>haugh: is it public anywhere? I'd love to look at that
<haugh>count3rmeasure, sorry, i'm in experimentation and long-term planning right now, and anything serious I write in the domain is likely to be someone else's property. I wonder if aconchillo is interested in supporting the GNU extensions directly, though. That could be an interesting contribution, but right now I'm just trying to get a better picture of how people use this stuff in practice.
<count3rmeasure>haugh: perfectly understand, good luck
<dsmith>198 nicks. Never been so close to 200!
<dsmith>200!