IRC channel logs

2023-03-10.log

back to list of logs

<daviid>1+ pretty amazing team - spritely is the next contemporary _and_ free s/w 'Symbolics Inc.' incarnation :) congrat all, excellent news - congrat robin!
<flatwhatson>ooh, does that mean we'll get a nice spritely keyboard? :D
<flatwhatson> https://www.rcsri.org/collection/symbolics-keyboards/symbolics-keyboard-1.jpg
<flatwhatson>accelerate your scheme coding by typing Greek-Q instead of L A M B D A
<cow_2001>i've found guile-config which makes writing command line programs easier than just optargs-long(?)
<rekado>cow_2001: I use guile-config in all my projects. I like that it’s declarative and results in a consistent configuration interface.
<cow_2001>O_O
<rekado>cow_2001: in the GWL I actually did feel the need to process *one* option with srfi-37, though. That’s because guile-config does not (or did not) allow for multiple instances of the same option to be passed.
<rekado> https://gitlab.com/a-sassmannshausen/guile-config/-/issues/15
<rekado>looks like there *is* a way to do that now
<cow_2001>doing SICP exercises 2.28 or so
<cow_2001>i'm getting dizzy
<cow_2001>just finished 2.28, actuall
<cow_2001>actually
<cow_2001>srfi-64 is *so* useful for that.
<cow_2001>some "solutions" aren't, like the probabilistic primes finder. https://git.sr.ht/~kakafarm/sicp/tree/master/item/guile.scm
<haugh>guile-config looks wonderful. thanks rekado for already opening issues about all my concerns :)
<haugh>All this time I've been trying to find an elegant way of using (guix records) in my own modules and I guess it never occurred to me to just copy-paste it into the repo
<haugh>elegant
<mwette>new wingolog post today
<Zelphir>About the org-mode source blocks :var header arguments thing: Here is my fix: https://lists.gnu.org/archive/html/emacs-orgmode/2023-03/msg00163.html Seems to work fine for me.
<old>So I've been working on a configuration library purely in Guile for my project as a replacement to autoconf. Here's my current usag of it in a C project that has Guile bindings
<old> https://paste.sr.ht/~old/156ebabd2c7de3a223f68dc7585b1785dc35294e
<old>I'm in the process of gluing this with a "make" variant purely written in Guile so that the entire build system is pure scheme
<old>I try to respect the GNU convention with all of the standard configuration stuff like --target, --host, --prefix, etc.
<old>labeled as "standard-directory-variables"
<msavoritias>oh nice :D
<mwette>I'm reading and digging into the VM bytecodes. When a closure is generated in allocated memory the proc-address is in word 1, captured env in in words 2 .. n. I'm guessing word 0 is a vtable. If so, what vtable?
<mwette>If not, then what?