IRC channel logs

2023-02-26.log

back to list of logs

<dsmith>old, Ever seen brl?
<dsmith>"beautiful Report Language"
<dsmith>] and [ are string quote chars, and starts out in string quote
<dsmith>So this is just text with [(scheme expressions)] between square brackets
<dsmith> https://brl.sourceforge.net/brl_4.html#SEC18
<old>dsmith: this is what I want!
<old>I think it's easily doable in Guile with sandboxed environment and on the fly evaluation in it
<flatwhatson>old: that sounds a lot like Skribilo: https://www.nongnu.org/skribilo/
<flatwhatson>maybe inside-out from the suggestion above, it's scheme with [] delimited strings and ,() to unquote back to scheme
<dsmith>I sorta kinda ported brl to Guile years ago. Used #> and <# for the string delimiters.
<dsmith>Let me see if I can find that...
<dsmith>Nope. Looks like I never checked that in.
<old>flatwhatson: Skribilo looks like a winner here
<old>I see however that is it call from the CLI
<old>I wonder if it's possible to have the following procedure:
<old>(define* (skrib-from-file input-port output-port #:key (bindings '()) (module (make-sandbox-module bindings))) ...)
<old>so I can generate from Guile file on the fly in a safe sandboxed environment with some parameters pass to it
<old>I also see that there's a concept of target-engine. hmm. I'll have to dig this further
<civodul>flatwhatson: hi! while working on updating libgc to 8.2.2 in Guix, i stumbled upon https://github.com/ivmai/bdwgc/issues/353
<civodul>AIUI, the test-out-of-memory test failure should be gone with 8.2, right?
<sneek>dsmith: Greetings!!
<old>support for typedef and enumeration: https://paste.sr.ht/~old/39e63f9d1311c2e2c5e810caa370690d0898eca3
<old>Allow for enum type in C structure, auto increment of enum member like in C
<old>Allow also for typedef of type that can then be used in structure
<flatwhatson>civodul: yes that should fix the test, but i can't remember if i verified that post-merge
<flatwhatson>i can do a guile build against bdwgc-8.2 and try it out later today
<civodul>flatwhatson: i tried "guix build guile --with-latest=libgc" and it went well, though that's still with the skipped test
<old>and here's union: https://paste.sr.ht/~old/a56b8ec48c44a24a9e58c6e8d42ae5b0c02609a5
<old>Going to do now procedure and module interface