IRC channel logs

2023-02-19.log

back to list of logs

<chrislck>sneek: botsnack
<sneek>:)
<lechner>Hi, my channel bot for #guix crashed with this message when trying to process the URL https://www.irccloud.com/pastebin/raw/JSa3ILCV/file.txt Does it look like a bug in web/http.scm to anybody else? Thanks! https://www.pastery.net/jpzyyw/
<lechner>specifically, "web/http.scm:252:2: In procedure parse-non-negative-integer: Bad non-negative-integer header component: 31536000;max-age=0"
<mirai> <https://developer.mozilla.org/en-US/docs/Web/HTTP/Headers/Cache-Control>
<mirai>they're using semi-colons instead of commas
<mirai>guile is doing it right™ by throwing exception IMO
<cow_2001>in https://www.gnu.org/software/guile/manual/html_node/index.html, pressing "Up: (dir)" will get you to https://www.gnu.org/software/guile/manual/dir_html/index.html which is a 404
<cow_2001>maybe i should tell #gnu or #fsf about that? or some mailing list. they love mailing lists.
<cow_2001>sent to webmasters email
<lechner>i have seen that as well
<drakonis> https://idiomdrottning.org/match-generics
<mwette>so dumb that dsssl was replaced by xslt
<mwette>so glad that Oleg created sxml
<cow_2001>okay okay. you cannot re-(define) a procedure's argument.
<old>eeh (format #f "~p" 0) => "s"
<old>Why is that? Plural means >= 2 no?
<old>the manual says: plural != 1
<old>I'm no linguist, but I think this is wrong
<pussipupu>No, plural means != 0
<pussipupu>There are zero bananas
<pussipupu>Erm, != 1, sorry
<old>eeh maybe this is english specific
<pussipupu>It depends on what number inflections your language has
<pussipupu>Many languages have singular, dual and plural for instance
<old>I know that in french plural means >= 2, thus zero is singular
<old>thanks for the precision. TIL that zero is plural in english.
<pussipupu>What's -1 <noun> in French?
<old>minus one something?
<pussipupu>Yeah, but is it something or somethings?
<pussipupu>Is the noun in the plural there?
<old>singular
<pussipupu>Interesting, thanks :)
<old>we would write it as "moins une pomme" == "-1 apple"
<old>and "une pomme" == "1 apple"
<old>But "deux pommes" == "2 apples"
<old>and "zéro pomme" == "0 apples"
<old>fascinating
<old>And so I guess "1.5 apples" also?
<pussipupu>Yeah
<old>fascinating
<pussipupu>But 0.5 apples can often be “half an apple”
<old>Hmm I see
<pussipupu>Finnish is a bit weird(to me) in that for nominative noun phrases with specific numbers other than one, the number is in the nominative singular and the noun is in the partitive singular
<cow_2001>i have a symbol. how do i get the value associated with it?
<lilyp>cow_2001: (module-ref some-module the-symbol) ?
<cow_2001>hmm
<cow_2001>then (module-ref (current-module) 'f)
<cow_2001>this raises an exception
<cow_2001>when f is not in current module
<cow_2001>there is module-symbol-interned? and stuff
<cow_2001>hmm. get-line in ice-9's textual-ports does not include new lines. if i do something like `printf 'moo' | some-cat-like-guile-program` and it is running at a loop around get-line, you have to do something like a `(display line) (newline)` at each iteration, it would print a new line even through `printf 'moo' | cat` would not