IRC channel logs

2023-02-11.log

back to list of logs

<old>looks promising. Can do nest types: https://paste.sr.ht/~old/d36fad2bba60522d84154977639fd7bb35243443
<daviid>old: all great, but why do you need to represent a point or a rectangle in C?
<mwette>that was quick
<apteryx>any reason why #:autoload (json) (json->scm) would yield: Failed to autoload json->scm in (json): Throw to key `unbound-variable' with args `("resolve-interface" "no binding `~A' in module ~A" (json->scm (json)) #f)'. ?
<apteryx>if I run 'guile' then ,use (json), it works
<apteryx>ah, the "real" module exporting it is (json parser); if I use that, it works as expected
<old>daviid: It is a basic example. But it could already be used for manipulating SDL_Rect and SDL_Point
<sneek>wb lechner
<stis>Greetings folks!
<stis>Nice new post by wingo at wingolog.org
<mwette>stis: thx
<mwette>What happened with the debugger discussion?
<stis>dont know, been researching my heritage some time no so playing an amatear historion on my bllodline. Actually more fun than I thought. I even get the feeling to be an aurther and write a book about what I find and fantasize about historic times
<stis>Right know I'm cooking a fantastic beef bourgone and coding again sinse christmas
<stis>mwette: ^^
<stis>I'm actually hungry as hell as I have this insane idea of training 10min / hour for 10 hours a day
<stis>burn about 120kcal ecch 10min pass
<stis>all to loos weight as I'm too heavy atm
<stis>sum(i for i in range(1000000000)) in guile python i slike 40X faster :-)
<stis>clocks about 1 sec in guile, but try to do that in python3 and you will be boored ;-)
<stis>Maybe I should try to make a new release now of guile python, WDYT?
<Zambyte>Hi, I'm trying to run the examples in the g-golf repository, but all of them give me the following error: `No applicable method for #<<generic> g-application-run (1)> in call (g-application-run #<<gtk-application> 7f91b1299030>`
<Zambyte>I'm running it in a guix shell with guile-g-golf, guile, and gtk. Anyone know what I might be missing?
<daviid>Zambyte: please try to get some help from #guix, also, make sure you use the very latest, just released, v0.8.0-a.3 version
<mwette>So, Whippet uses 1/16 heap for itself? (I'm not complaining, just want to know.)
<daviid>Zambyte: all example work fine on all other distro
<daviid>Zambyte: my suspicion is you are running those examples from the released version, but an older version is installed
<daviid>Zambyte: the latest release precisely changed all examples, to adapt to the new 'skip array length' mechanism in place in v0.8.0-a.3 version
<stis>mwette, yep thats looks like the overhead, not too terrible if you ask me, seams that, as usual, wingo does axcellent work!
<stis>mwette: ^^
<stis>I'm also curious to move my gc hack for prolog over to this environment. I use a hacked bdw-gc to make that roll
<stis>I think that this ectra byte is a perfect tool tom implement this and as I know wingo will make it hackable, the joy will be for everybody
<stis>Jeesus wht a nice receipt I found. Investing in being able to cook is one of my best investments I ever done, no need for restaurants.
<stis>google translate this one and you will thank me (if you like meat) https://www.ica.se/recept/boeuf-bourguignon-med-potatismos-726038/?fbclid=IwAR3Tc7An-O9hUK0InqDrV0W3IFS8UiaBoIxJDzxBZscy7oxSs7rhJHFkA38
<Zambyte>daviid: I did have a version mismatch, I was using g-golf v0.8.0-a.1 from the Guix repos. Using the example from that tag in g-golf works :)
<stis>Hmm, I need to get some feeling, I'll see if I can find some music by queen ...
<stis>then a conjack and some hacking ...
<daviid>Zambyte: ok great, now try to build and use the latest ... quite a few important buggs have been fixed ...
<daviid>stis: https://lists.gnu.org/archive/html/lilypond-user/2023-02/msg00163.html - wdyt? could we recommand python on guile or that wouldn't work?
<stis>daviid: I would say most program actually can be used by guile python, but some of the itraspections does not work and th emodule system is not entirely the same as python3, so usually one need to install the code manually
<stis>I can try to test install it to see if it works ...
<stis>daviid: ^^
<daviid>stis: i am not 'very interested' myself, but wanted to let you know about the attempt ... if you feel like it,you couldanswer them ...
<stis>ok, thanks!
<stis>daviid: im in th emidle of developmen, sorting out som bugs, but most dependencies of pyqrcode seam to compile
<stis>but not there yet that I can compile it
<daviid>old: nice - fwiw, given their definition - https://wiki.libsdl.org/SDL2/SDL_Rect - i would simply represent those using lists, and simply use make-c-struct parse-c-struct in the 'backend - note that guix has, somewhere i forgot, in guix utils, a make-c-struct parse-c-struct 'compiled' approach, which i'd like to see in core guile