IRC channel logs

2023-01-18.log

back to list of logs

<lloda>mwette: http://paste.debian.net/1267622
<lloda>the error is clear in the preprocessed line, but i don't see where the *(int *)& is coming from :-|
<flatwhatson>maybe an op can /kb argv?
<mwette>lloda: here is my c-parse tree for that https://paste.debian.net/1267635/
<apteryx>sneek: later tell civodul thanks for the define-c-struct tip
<sneek>Will do.
<mwette>maybe add in W_EXITCODE(X,Y) and WEXITSTATUS(Z) and verify(T) and see what they produce
<apteryx>can I get the actual file name of an imported module in Guile?
<lilyp>apteryx: (current-filename) inside the module
<kori>wingo: argv's joins/parts are quite noisy...
<flatwhatson>someone please ban argv
<mfiano>I didn't notice until someone pointed it out so I could disable smart filtering.
<mfiano>Showing joins/parts for everyone is like usenet without a killfile. Don't know how everyone deals with that :)
<civodul>hmm this is annoying
<sneek>Welcome back civodul, you have 1 message!
<sneek>civodul, apteryx says: thanks for the define-c-struct tip
<civodul>i can't find the right incantation to use in such a situation
<lloda>mwette: thx, i'll try again tonight
<lloda>the add-a-space trick here https://www.gnu.org/software/emacs/manual/html_node/emacs/Lisp-Indent.html doesn't seem to work for me in any mode i try
<nckx>I'd not heard of that hack but it works for me in Elisp/d mode and Guile Scheme mode.
<nckx>civodul: Did argv go away on their own?
<nckx>For future reference: /mode #chan +b argv!*@*$##fix-your-connection
<nckx>So <mask>[$<redirect>]
<nckx>##f-y-c is just a channel dedicated to this purpose, to hopefully make the ban less mysterious when they return.
<apteryx>lilyp: at the REPL this returns #f unfortunately
<civodul>nckx: i temporarily banned them via ChanServ, using a commands you had taught me long ago :-)
<civodul>found it in my notes
<civodul>didn't know about ##f-y-c
<civodul>the posix_spawn code fails to (cross-)build to MinGW: https://paste.debian.net/1267676/
<civodul>Gnulib says it's supposed to fix that
<nckx>civodul: Okido, that wasn't visible in my logs. FYI, I've unbanned them in Guix, the attempts have stopped.
<nckx>* #guix — habit.
<sneek>dsmith-work: wb!!
<dsmith-work>sneek: botsnack
<sneek>:)
<dsmith-work>So what is "argv" ?
<chrislck>ACTION reading about HEPA filters... why do they call themselves CADR? lol
<civodul>dsmith-work: it's someone on this channel who had connection issues
<dsmith-work>Ahh. Thanks
<civodul>jpoiret: in the posix_spawn patch set, you mention Gnulib 0.1.5414-8204d but i can't find what commit that refers to
<civodul>do you happen to have more info?
<civodul>(looks like we're using the posix_spawnp module but not the posix_spawn module, so we'll have to update Gnulib)
<jpoiret>I don't think I have any other info, this was probably printed in the terminal when i updated gnulib...
<old>lloda: Thank for the link of this space tricks. Did not know about it and it's very useful
<civodul>ACTION goes for a full Gnulib update, crosses fingers
<lilyp>apteryx: you don't have a current file name in the REPL tho? (or you you mean getcwd?)
<lloda>old: yw, wish it worked for me :'(
<lloda>hmm it might be a new feature. It works on 28.2 but not in 27.1
<old>Is there a way to prevent Guile from reducing a rational?
<old>i.e., (/ 8 16) I would like to keep it 8/16 and not 1/2
<lloda>there's no way to do that
<old>Okay thanks
<old>Throw to key `numerical-overflow' with args `("/" "Numerical overflow" #f #f)'In which a floating divison can give a numerical overflow?
<old>I would expect to have +inf.0
<old>oh wow that's weird
<old>(/ 1E9 0) and (/ 1E9 (string->number "0")) work
<old>but echo "0" | guile -c '(/ 1E9 (string->number ((@ (ice-9 textual-ports) get-line) (current-input-port))))' does not work
<lloda>/ isn't a floating point division, it's overloaded. Compare (/ 1 2) vs (/ 1 2.) or (/ 1 0) vs (/ 1. 0)
<lloda>your echo line looks like a Guile bug to me
<lloda>tbh the 'numerical overflow' message is a bit dodgy. It should just be 'divide by zero'
<old>I did get divide by zero on the CLI
<old>but in one of my script, I got the numerical overflow
<old>The behavior when doing so with a port is weird
<old>It shoudl return infinity
<civodul>ACTION completed Gnulib update, now testing
<mirai>where is peg-string-compile found at?
<mirai>ice-9/boot-9.scm:1685:16: In procedure raise-exception:
<mirai>Unbound variable: peg-string-compile
<mirai>(ice-9 peg) is already imported