IRC channel logs

2023-01-02.log

back to list of logs

<ham5urg>Is it a big step to implement network-namespacing support for Guix? I would like to run a container with an own virtual NIC (pesudo VM) like here https://guix.gnu.org/en/cookbook/en/html_node/Container-Networking.html#Container-Networking . My critic with that example is that it is not quite a Guix-ish way to do it. Guile offers links, routes and routes. Could a net-namespacing be added?
<elevenkb>Is there a way to modify a flattened assoc list like `'(#:key-1 1 #:key-2 2)` ?
<elevenkb>sorry better to just write it `(#:key1 1 #:key2 2)` ?
<festerdam>mwette: Thanks! How do you know it's in cps/intmap.scm?
<elevenkb>Nevermind about my question, will maybe ask it later.
<elevenkb>Found a different way to address the wider surrounding issue.
<mwette>festerdam: I did a search through all guile .scm's and .c's. So not 100% sure but that looks pretty likely.
<mwette>I found this: (error "not found" i)
<mfiano>mwette: Thanks, but there is no GL5.
<mwette>mfiano: It's been a while since I looked into OpenGL. Maybe I was thinking 3 vs 4.
<mwette>checking what my demo pulls in (on ubuntu 22.04)
<mfiano>Ah yeah you ant at least 4.3 for the modern stuff.
<mfiano>want*
<mfiano>4.6 is supported by even 5-6 year old intel CPUs
<mwette>demo works, looking like GL 4.6
<count3rmeasure>is there a generic predicate like "type?" that would give me a given objects type at the time of evaluation?
<mfiano>count3rmeasure: there should be a generic function for GOOPS classes, `class?`, but I'm not aware of any others (but I'm fairly new)
<mfiano>or was it class-of like CL.
<count3rmeasure>fair enough, thank you mfiano
<mfiano>No idea, but it models CL closely, so it must
<mwette>In the nyacc/examples/ffi directory is glugl.ffi, which when compiled to glugl.scm provides access to all the GL/gl.h and GL/glu.h API.
<mfiano>mwette: I see, thanks. Though the time consuming part of a GL wrapper is the higher level wrapper.
<mfiano>I don't expect any language to do any better than cl-opengl here, but one can wish :)