IRC channel logs

2022-12-24.log

back to list of logs

<old>Anybody has an idea how to use system-error-errno on a exception passed to with-exception-handler?
<old>The docoumentation shows an example with `catch`
<old>I guess one can do: (system-error-errno (cons (exception-kind exn) (excpetion-args exn)))
<haugh>Can we map procs to multiple values without intermediate lists?
<haugh>as in (receive (a b) (2vals) (values (proc a) (proc b)))
<mfiano>call-with-values can do that
<lilyp>or srfi 71 let
<haugh>doesn't the second argument to call-with-values (consumer) still require a correct-arity procedure?
<haugh>I want to take and return any N values without a rest list
<lilyp>either you know the arity or you take a list, there's no in-between :)