IRC channel logs

2022-12-12.log

back to list of logs

<apteryx>I still don't have a clue as to why using the meta switch of guile doesn't work the way I'd expect in this example: https://paste.debian.net/1263834/
<apteryx>gabber: what kind of special ASCII?
<dsmith-work>That's a backslash \ not a slash /
<dsmith-work>Wait
<dsmith-work>Sorry, I was thinking of something else...
<dsmith-work>apteryx: There used to be a length limitation on #! I wonder if there still is one
<apteryx>dsmith-work: right, \ is handled by Guile, documented as the meta switch
<dsmith-work>Yep. I was thinging #!/really/really/long/path/to/guile
<apteryx>one of the example in info '(guile) Scripting Examples' doesn't seem to work; loading the 'fact' file doesn't make its 'fact' procedure definition available because it is private
<dsmith-work>But looks like it's 127 nowadays
<apteryx>OK
<apteryx>in the (fac) module example, running I get: "<unknown-location>: warning: possibly unbound variable `fact'"
<apteryx>and it doesn't seem to do anything ./fac.scm 4 24 -> (no output), exit status 0
<apteryx>hm. I tried many things, with guile directly, and I don't think it works as intended, unless I'm doing something silly (likely)
<apteryx>here's what I tried: https://paste.debian.net/1263837/
<gabber>apteryx: non-printable characters like the "escape character" and others
<apteryx>about my issue with the guile scripting example; it was already reported as #36682.
<apteryx>I've replied to it with the odd error I get after applying Arne's suggestions: ice-9/read.scm:126:4: In procedure lp #<unknown port>:1:4: unexpected end of input while searching for: )
<apteryx>the basic error in the doc is that we can't mix plain scripts and modules together; they live in different namespaces
<apteryx>seems we can't mix -e with a module; this triggers the above error
<apteryx>one solution: replace (@@ (module-name) main) with (module-name), but then you must export module-name
<apteryx>err, you must export 'main'
<apteryx>ah, the Guile compile script makes use of 'with-target'. I guess it's wired correctly after all.
<apteryx>dsmith-work: file says "ELF 32-bit LSB shared object, [...]"