IRC channel logs

2022-12-04.log

back to list of logs

<old>What's aoc?
<flatwhatson> https://adventofcode.com/
<old>oh
<old>oh sweet
<mwette>Hi All. After starting the guile repl server in a terminal, connect then quit from emacs using geiser's "connect-to-guile". When I quit I alway see "Wrong type to apply: ()" in the terminal. No other error messages appear. However, looking at (ice-9 top-repl) this looks suspect: https://git.savannah.gnu.org/cgit/guile.git/tree/module/ice-9/top-repl.scm#n43 Any ideas?
<old>flatwhatson: Is there any advantage to authenticate for aoc?
<flatwhatson>old: i think you need to auth to get the proper puzzle
<flatwhatson>after you do the first part, there's a second puzzle using the same data
<old>oh okay
<old>well time to remove the dust from that github account
<old>AH okay you get specific input
<spk121>mwette: there once was a patch where sigaction was returning *unspecified* that caused a similar problem, but I don't think that patch is still around
<spk121>so, yeah, no idea
<mwette>spk121: thanks. I did find this obscure report: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=32040
<mwette>spk121: thanks for the reply, btw
<daviid>spk121: tx, i actually had patched g-golf before you answered, but tx
<daviid>spk121: i only patched ulong though, i se you did that for int and short, are there architecture 'out-there' that have (sizeof int) != 4, and sizeof short = 2?
<daviid>float and double might cause problems i guess
<spk121>daviid: you can be pretty confident of short being 2 on any system that runs Guile. Short is 8 bytes on Unicos, haha
<spk121>int was 8 on some types of Solaris
<spk121>but this is all too obscure or ancient to worry about
<spk121>int is 2 bytes on some PIC controllers,
<clh3>daviid: Thanks! The test suite passes on i686 now.
<sneek>Welcome back clh3, you have 1 message!
<sneek>clh3, daviid says: I fixed and pushed, on the devel branch, please try and let me know if everything is ok now, tx
<spk121>aaaaand just to wrap up this trivia: in the C23 standard, the minimum sizes are char 1, short 2, int 2, long 4 and long long 8. With the maximum sizes unspecified
<daviid>spk121: i think i may have to fix those - https://git.savannah.gnu.org/cgit/g-golf.git/tree/g-golf/gi/common-types.scm?h=devel#n225, for boolean, float and double (?)
<daviid>clh3: great! did you install gtk4 or only gtk3? i am curious to solve this peg-solitaire problem you seemed to have ... but it requires gtk4
<clh3>daviid: I have gtk4 now. I have two files defining guix package definitions for g-golf: one with gtk3, and one with gtk4. So I can go back and forth as needed.
<daviid>g-golf doesn not require any [except for the 'bad' tests that i have to get rid of], so you should only have one g-golf package [one per guile version actually, but not one per gtk version ...]
<daviid>clh3: what about the peg-solitaire example? and all other examples, i'd be happy to know if they work fie for you
<clh3>daviid: I haven't tested if Guix can install both the package for gtk4 and the package for gtk3 to the same shell, that's why I have two files.
<daviid>clh3: i think guix hapily install multiple gtk-xx versions, just as any other distro
<daviid>the problem might also be the gtk-4 version, i use and check using 4.8 here (debian testing
<clh3>daviid: for peg-solitaire I expect the squares in the grid to appear with a purple/pink color as shown in examples/gtk-4/peg-solitare.png. But when I run the program, the squares are gray.
<daviid>ok, there are quite a lot of possible things causing problem, 1st do you have any warning in the terminalk where you launched the peg app?
<clh3>daviid: nope, no warning or output in the terminal
<daviid>clh3: also, can you try all other examples, all other examples are quite a lot more simple, it will only take a few miutes ... for the revealers, you need a specific gnome desktop setting ...
<clh3>daviid: oops meant white. Now that I am looking at it again the squares are white with agray border
<clh3>revealer is k
<clh3>* ok
<daviid>ok great, try the clipboard
<daviid>what gtk4 version is in guix?
<clh3>daviid: the "gtk" package is 4.8.1
<daviid>perfect
<civodul> https://packages.guix.gnu.org/packages/gtk/
<civodul>(the new package browser!)
<daviid>civodul: very nice!
<clh3>wait I have an old guix checkout, it may be newer
<clh3>daviid: clipboard is showing some output
<clh3>g-golf/examples/gtk-4$ ../../pre-inst-env ./clipboard.scm
<clh3>Backtrace:
<clh3>In ice-9/boot-9.scm:
<clh3> 1752:10 12 (with-exception-handler _ _ #:unwind? _ # _)
<clh3>In unknown file:
<clh3> 11 (apply-smob/0 #<thunk 879a570>)
<clh3>In ice-9/boot-9.scm:
<clh3> 724:2 10 (call-with-prompt _ _ #<procedure default-prompt-handle…>)
<clh3>In ice-9/eval.scm:
<clh3> 619:8 9 (_ #(#(#<directory (guile-user) 878a690>)))
<clh3>In examples/gtk-4/clipboard.scm:
<clh3> 164:18 8 (main _)
<clh3>In g-golf/hl-api/function.scm:
<clh3> 86:19 7 (_ . _)
<clh3>In unknown file:
<clh3>Exception thrown while printing backtrace:
<clh3>In procedure primitive-call-ip: Wrong type argument in position 1 (expecting PRIMITIVE_P): #<procedure 88c9700 (_ _ _ _ _ _ _)>
<clh3>g-golf/hl-api/gobject.scm:506:17: No such GInterface : <gdk-event-translator>
<daviid>clh3: please use a paste bin service, tor-friendly, when pasting more then 2 or 3 lines, tx
<daviid>debian or https://paste.rs/web
<daviid>even i can't easily read code further less erros in irc ...
<daviid>and it annoys all other users ...
<clh3>daviid: apologies, it's my first time using IRC to exchange error output. I have bookmarked that site now.
<clh3> https://paste.rs/0BA
<daviid> https://paste.centos.org/ is a nice pste service, it has an interface as well, but it only allows 24h paste
<daviid>clh3: ok, so if you installed c-colf, you should be able to run the examples by cd ...; ./peg-solitaire.scm [chmod a+x if not already the case]
<daviid>then i never seen that error
<clh3>daviid: I have run `make' in the build directory, but I haven't been using `make install'
<clh3>I guess I have some anxiety about potential incomplete uninstalls
<daviid>g-golf make uninstall is safe
<lxsameer>hey folks, how can I found out the installation path of a module I load?
<daviid>but it's prob not the cause of the prob anyway, the problem is i can't reproduce thism, and never saw that message
<daviid>clh3: this error, comes just launching the app or trying it?
<daviid>clh3: is your guix the main system or is guix hosted?
<lxsameer>hey folks, is there any working lsp server for guile?
<lxsameer>b
<clh3>daviid: guix hosted on trisquel, guix shell --pure --no-grafts
<daviid>clh3: ok, can you try this
<clh3>daviid: this error comes 4-5 seconds after entering the command at terminal, no window appears
<daviid>hum, just a few min, need to think
<daviid>i suspect something is wrong in your environment, but it's hard to guess
<clh3>I also have LTDL_LIBRARY_PATH=$LIBRARY_PATH in the shell
<daviid>if trisquel has gtk4, you could try in trisquel - that would be usefull, not to exclude guix of course, but to try to understand ...
<clh3>daviid: i686 unfortunately unsupported for latest trisquel (as far as I know), and for my current version I'm not getting any hits for variations of "gtk4" search string in synaptic package manager
<clh3>daviid: I'd like to try to isolate this error on my own time; I wasn't seeing it earlier
<clh3>also need to eat now
<mwette>It might be nice to have guile module for type sizes and alignments. nyacc has https://git.savannah.nongnu.org/cgit/nyacc.git/tree/module/nyacc/lang/arch-info.scm (including for 8-bit AVRs, which I'm using.
<civodul>mwette: there's (system base target) and (system foreign) but it's not quite the same as what you have here
<mwette>civodul: Thanks. Yes, that is not the same but the target naming is something I should adopt.
<daviid>clh3: i'll patch the procedure that raises the error to get the parent class name as well - fyi, those are 'so-called' runtime classes [and runtime interfaces], so they are built 'on-demand' not imported, and this one, is a none public interface, that is only there on a per backend model, X11, wayland ...
<daviid>clh3: i pushd a patch to get the class name that implement the missing (runtime) interface, could you grab, build and try the clipboard example again, then paste the error message again ... tx
<daviid>clh3: you said I'd like to try to isolate this error on my own time; I wasn't seeing it earlier
<daviid>clh3: did the clipboard example worked 'before'? that doesn't sound plausible to me, but ...
<clh3>daviid: my recollections of clipboard.scm working were on my patched personal branch, possibly with a different xorg package I was using while trying to find the right guix package recipe
<daviid>clh3: '... possibly with a different xorg package ' very scary :)
<daviid>what desktop are you using in guix, and what backend?
<clh3>:D
<daviid>i didn't know you could 'pickup the xorg version 'by yurself', but that guix would install what ever is needed to run your desktop ... fwiw, here i am using wayland, but i also never had problem when i was using X11
<daviid>clh3: meanwhile can you grab the lates devel g-golf and compile ... then run the example again?
<clh3>this is my current package definition that uses gtk4: https://paste.debian.net/1262873/ which is using a version of xorg for tests. I'm not quite sure how guix shell interacts with the host OS (Trisquel) MATE desktop (and related xorg server) without a container.
<clh3>g-golf devel branch clipboard.scm output: https://paste.debian.net/1262875/
<daviid>i would remove the gtk, clutter and xorg-server-for-tests dependencies, not run the tests, and make sure 'guix uses your mate desktop' with zero alteration - if that even makes sene ...
<daviid>it's ufortunate you are using trisquel, so to speak, a debian testingf would have given you the opportunity to constantly check and compare between the debian and guix environement ...
<daviid>anyway, this is very likely the source of your problem running the peg game example ...
<jlicht>what's a tidy way to do map-and-filter on a list?
<daviid>jlicht: filter-map
<jlicht>thanks, I overcomplicated my ddg queries XD
<lxsameer>hey folks, is there any convention on the structure of a library in Guile?
<daviid>clh3: i have no idea how guix interacts with the desktop/backend, you should explain and try to get some help in #guix -
<cwebber>hm hm
<cwebber>hmmmmm
<cwebber>okay
<cwebber>so, automake question really, but hopefully ok to ask here
<cwebber> https://gitlab.com/dustyweb/terminal-phase/-/blob/guile/Makefile.am#L113 how do I make this a dependency of the general "make" step?
<cwebber>currently you have to run "make terminal-phase/install-paaths.scm" manually and that's not ideal
<cwebber>oh
<cwebber>I have a feeling I did this wrong :(
<cwebber>sigh
<cwebber>I have no idea what the right path is to adding assets to a project like this which you can use in dev mode but also which get installed right. I did my best and I don't even remember where I borrowed from.
<daviid>cwebber: if no one can help here you may try ##workingset, there are very nice and very helpful ... at least ime
<civodul>cwebber: hi! maybe you can add .../paths.scm to BUILT_SOURCES?
<civodul>BUILT_SOURCES are things that get built first
<civodul>(info "(automake) Sources")
<cwebber>civodul: oh!
<cwebber>okay yes
<cwebber>civodul: thank you
<daviid>clh3: i see your are not in #guix :)
<cwebber>beautiful. that worked
<cwebber>thanks civodul
<civodul>yay!
<lxsameer>hey folks, I'm using `guix system` to build a customize image, is it possible to copy a file to a certain location while using `operating-system` ?
<daviid>lxsameer: you'd have more luck asking in #guix
<lxsameer>oh geez, I thought I'm asking in that channel :)))
<daviid>clh3: in #guix, you'll have the possibility to talk to 'backend' experts, those who make things happen when running guix as a host ...
<daviid>spk121: i am now told on #gnome-introspection i shouldn't ue unsigned-long for GType, cause on ouindoze, even 64bits, it's 4 bytes... pfouuuwww
<spk121>daviid: guile-gi presumes GType can be cast to a size_t. Since it is unsigned, and since it is only cast, never operated on, that's fairly safe
<daviid>spk121: right - i knew you did the right thing :) if only i knew ...
<daviid>it's ok though, i'll fix that now, annoying but there are worth things in life :)
<daviid>i have no idea where i got the idea that a GType was an unsigned-long, but i did copy that from 'somewhere' :)