IRC channel logs

2022-11-02.log

back to list of logs

<mwette>I found this reference on match, looking for origin: https://3e8.org/pub/scheme/doc/match.pdf
<sneek>Welcome back mwette, you have 1 message!
<sneek>mwette, apteryx says: the problem I'm now trying to solve is the "expanding a binary tree as it is traversed" test at https://paste.debian.net/1257994/
<mwette>Also, wrt, scheme window managers, I've used sawfish a while ago, but now I'm on wayland, and not sure X11 managers are going to live long.
<mwette>Just for fun, I'm playing with writing guile-based app on wayland which talks to the socket directly, using guile to translate the xml-based protocol def'n to scheme. And working to add sendmsg & recvmsg to sockets.
<mwette>also w/ fibers
<flatwhatson>the beginning of a guile wlroots kind of thing?
<mwette>not familiar with wlroots. I'm just playing, not really sure what will turn out
<old>sneek: later tell lampilelo guile-parallel 10% faster than guile-fibers with a hashed double-ended queue. Without work stealing!
<sneek>Will do.
<old>sneek: botsnack
<sneek>:)
<lechner>sneek: later tell mwette: Did you see this talk? https://10years.guix.gnu.org/video/guile-wlroots/
<sneek>Okay.
<lechner>sneek: botsnack
<sneek>:)
***Ekho- is now known as Ekho
***civodul` is now known as civodul
<civodul>hi there!
<civodul>still stuck on that fibers leak: https://github.com/wingo/fibers/issues/65
<civodul>wingo: you around? :-)
<civodul>i'm looking for fresh ideas
<civodul>i don't understand why the "fix" has an effect
***civodul` is now known as civodul
<spk121>civodul: would running valgrind provide any benefit here?
<civodul>spk121: no, because it's really a data retention issue, the GC is operating correctly (presumably)
<dsmith-work>civodul: What was that other thing you used? "rr" ?
<dalepsmith[m]>sneek botsnack
<sneek>:)
<civodul>dsmith-work: rr saved my life a couple of times, but this time it's a different beast
<civodul>i need a heap profiler among other things
<civodul>(i sorta have a couple of tools in that area now)
*w0ll3q1uszxabiwo sent a scheme code block: https://libera.ems.host/_matrix/media/v3/download/libera.chat/3f336d41edb5e3889a35515aafcdd1a8963d93ed
*w0ll3q1uszxabiwo sent a code block: https://libera.ems.host/_matrix/media/v3/download/libera.chat/4ff6798db0d1fe8a203ea54bc53f685e35d76d25
<w0ll3q1uszxabiwo>How do i get keywords arguments for all of them to be optional?
<old>TIL what Phimosis is.
<old>w0ll3q1uszxabiwo: Keywords are always optional
<w0ll3q1uszxabiwo>Why is it giving me a wrong-number-of-args then? @_@
<w0ll3q1uszxabiwo>old: > Phimosis is defined as the inability to retract the skin (foreskin or prepuce) covering the head (glans) of the penis. -- https://en.wikipedia.org/wiki/Phimosis
<w0ll3q1uszxabiwo>In severe cases people have to go on a surgery to handle this issue which is risky so i designed this and it allowed my friend to avoid a surgery so making it into a better product with intention to publish it on thingiverse and stuff
<old>I knew that kids can have problem in their development with the foreskin. I didn't know it could transform into a medical issue later in adults
<old>Anyway, for the wrong number of arguments, from the little backtrace that I've seen, I don't think that `phimosis-ring` is the problem here.
<w0ll3q1uszxabiwo>ye it can end up as a major infection which is allegedly really painful and it's not limited just to kids there are 40yo people who have the same issue
<old>Like I said, keyword arguments are like optional arguments but are refered by label instead of position
<old>So the problem is probably somewhere else?
<w0ll3q1uszxabiwo>weird
<w0ll3q1uszxabiwo>unbound-variable: Unbound variable: define-module
<w0ll3q1uszxabiwo>Stack trace:
<w0ll3q1uszxabiwo>0: (eval (define-module (phimosis-ring main) #:use-module (libfive shapes) #:use-module (libfive transforms) #:use-module (libfive csg) #:use-module (libfive text) #:export (phimosis-ring)) #<module (#{ g666}#) 7f5dab81b780>)
<w0ll3q1uszxabiwo>1: 125000000
<w0ll3q1uszxabiwo>Seems like that the scheme running in libfive's editor is not guile 🤔
<w0ll3q1uszxabiwo>scheme doesn't have keyword arguments right
<old>It's part of a srfi I think but guile has it builtin
<old>I don't know what is libfive so I'm of no help here :/
*w0ll3q1uszxabiwo is trying to make it work in emacs now then
<w0ll3q1uszxabiwo>oh cylinder-z has wrong number of args that's why it was failing
<w0ll3q1uszxabiwo>thanks for the help ^-^
<old>Anytime :)
<daviid>rekado: it seems our guile logs is missing an entry for today's log - as my internet was quite unstable, i was looking at ...
<Zelphir>re dynamic-wind: I think I understand a little better now. I found Chris' explanation in that thread quite clear, but also the explanation in https://small.r7rs.org/attachment/r7rs.pdf helped a lot. Surprisingly clear as well. Usually I find such documents rather daunting.
<dsmith-work>daviid, rekado: Ya, I couldn't get to the logs yesterday evening.
<Zelphir>re dynamic-wind: Also good note Chris made about it being useful in cases, where the cases of handling an exception and ordinary leaving of dynamic context fall together.
<Zelphir>Probably still need some time to look at examples and really grasp it, but making progress : )
<dsmith-work>sneek later tell mwette what did you mean by "looking for origin"? Looking for the LaTeX source?
<sneek>Got it.
***daviid` is now known as daviid