IRC channel logs

2022-10-31.log

back to list of logs

<a12l>cwebber: Regarding your Scheme tutorial, should the Spritely Institutue be seen as a "co-author" to the tutorial, or something like a publisher or similar?
<a12l>Btw, I get warnings when I following a link to the the institutes website from DDG, https://www.spritely.institute/
<nckhexen>The certificate isn't valid for www.
***maximed is now known as antipode
<ArneBab>I wrote an example for a REST handling server: https://www.draketo.de/software/wisp-snippets#rest-endpoints ⇒ (define-handler 'GET "/hello" (hello-world-handler request body) ... )
<wingo>moo
<ArneBab>Hi wingo :-)
<cwebber>a12l: yes, they are the publisher
<a12l>cwebber: Thanks!
***nckhexen is now known as jeffbezos
<dsmith-work>UGT Greetings, Guilers
<dsmith-work>sneek: botsnack
<sneek>:)
<dsmith-work>!uptime
<sneek>I've been running for 3 days
<sneek>This system has been up 5 days, 14 hours, 21 minutes
<dsmith-work>So found more bug in the the bot's "metaphone" function causing it to crash.
<dsmith-work>Considering replacing it completely with something else.
<dsmith-work>I belive it was used in an attempt to "normalise" a nick.
<dsmith-work>It's used for the "seen" and "tell" lookups.
<dsmith-work>I think something better would be to simply strip off any trailing _ or '
<dsmith-work>Or whatever else most irc clients use de-duplicate a nick.
<dsmith-work>Metaphone: https://en.wikipedia.org/wiki/Metaphone
<dsmith-work>The code: https://gitlab.com/dalepsmith/sneek/-/blob/master/scripts/bot/metaphone.scm
<dsmith-work>Lots of bugs indexing a list off the end. (using second, third, etc.)
<dsmith-work>sneek: seen fred
<sneek>Not as far as I can remember.
<dsmith-work>sneek seen fredg
<dsmith-work>Bam!
***justHaunted is now known as DeliriumTremens_
***civodul` is now known as civodul
<chrislck>sneek: botsnack
<sneek>:)
<dsmith-work>*if* people used real english names for nicks, then metaphone makes sense.
***DeliriumTremens_ is now known as justache
<dsmith-work>But not everyone has an english name, and a could be just about anything anyway.
<jeffbezos>Some fuzziness might be nice, but I agree that this probably wasn't the way. RIP metaphone, I'd never heard of ye.
<jeffbezos>I seem to remember it also handling ‘nckx2’ and the like, which is nice. So would [m]. But that's starting to become quite the random list of ad hoc things.
<jeffbezos>Actually, the nckx2 thing was a double-edged sword. It's perfect 99% of the time. Then come the Guest nicks.
<dsmith-work>Guest nicks are effectivly random I think. Would you get the same guest nick on each connection?
<civodul>i'm pulling my hair on this fibers memory leak: https://github.com/wingo/fibers/issues/65
<civodul>i need fresh ideas and/or debugging tricks; if anyone has that, please share :-)
<dsmith-work>Survey of nick uniqifier chars. {he}xchat is #\_, erc is #\`. Any others?
<jao>dsmith-work, for someone spoiled by math in his youth, #\' seems a pretty obvious choice, and #\` a rather weird one
<dsmith-work>jao: Yeah, that makes sense.
<dsmith-work>So far I have #\_ #\- #\| #\` #\'
<spk121>#\☺
<cwebber>civodul: could you bisect your way to figuring out when the bug occured?
<cwebber>git bisect that is
<cwebber>magit has a nice bisect interface btw
<cwebber>you know it's after 1.0.0 and before 1.1.0 so there's your start range ;)
<cwebber>oh wait
<cwebber>well
<cwebber>actually even if this is a guile problem
<cwebber>okay nm
<cwebber>I'm not sure looking at the issue that my advice helps
<civodul>cwebber: advice is much appreciated! :-)
<civodul>i should try bisecting, you're right
<civodul>problem is, there was an overhaul in commit 2a4f707827105d041668f34b62daaff871c22c07 that's a likely culprit
<civodul>but it's a big commit
<cwebber>hmmm
<cwebber>well, you can test the commit before and that commit
<cwebber>and your bisect doesn't even need a tool ;)
<civodul>yeah
<cwebber>at least that will tell you something.
<civodul>right, let's do that
<civodul>thanks :-)
<cwebber>sure
<civodul>reverting 84addfbfc69e7dea63c4b9b08656d052043bcecf seems to solve it
<civodul>damnit, why didn't i bisect earlier?!
<civodul>thank you cwebber!!
<cwebber>civodul: :)
<cwebber>oh
<cwebber>wait didn't I submit something about this
<cwebber>I thought I did
<cwebber>I did!!
<cwebber>civodul: https://github.com/wingo/fibers/issues/58
<cwebber>civodul: literally the same commit!
<cwebber>I hadn't gotten around to looking at it again since then
<cwebber>civodul: so that created TWO problems
<cwebber>space AND time
<lechner>wow, we need to talk more with one another
<lechner>or you, rather
<cwebber>hi lechner
<cwebber>?
<cwebber>oh
<cwebber>about both discovering the same commit has problems?
<cwebber>yeah
<civodul>cwebber: woow, one commit, two bugs :-)
<cwebber>civodul: yeah. that one should prolly be rolled back :P
<cwebber>civodul: mentioned the connection on issue :)
<lechner>cwebber: i think civodul very much regretted not bisecting (or reading that issue from April)
<cwebber>bisecting is exactly the kind of handy, everyday tool that's easy to forget when you're knee deep in debugging something tricky
<old>Any way to have a backtrace of another thread?
<old>From a REPL
<rekado>dsmith-work: does the “[m]” count that the Matrix bridge seems to add to all nicks?
<rekado>(this shadow ban in #guile when you’re not authenticated is really annoying. I keep having to check the logs to see if my messages went through…)
<cwebber>old: you'd have to capture it somewhere iirc
<cwebber>I don't think there's anything built-in
<old>hmmm okay
*cwebber steps afk
<Zelphir>Hi! Can anyone ELI5 dynamic-wind? I read https://www.gnu.org/software/guile/manual/html_node/Dynamic-Wind.html, but I don't understand a thing, and I would like to understand some code, which makes use of dynamic-wind. Or maybe you could point me to an easier to understand explanation what it is?
<spk121>[m] means matrix? All this time I thought it was gender
<spk121>Zelphir: imagine a house, every time you enter you take off your shoes and when you leave you put on your shoes. There are many ways to enter the house or leave the house, but, no matter what you do in the house or which way you enter or leave (either normally or in some erroneous way) you do the shoes.
<spk121>dynamic-wind sets up the house, and in-guard and out-guard is the rule that you must follow when you enter or leave
<Zelphir>So, is it like a decorator kind of, which decorates a function, so that it does something at the start and at the end? What is a dynamic context? Is it simply the entirety of what is in the environment at the time of the function call?
<spk121>Oh, if you want a technically correct answer, ask a real CS person. Something to do with the state of the stack when you enter or leave
<Zelphir>hm OK at least I am not completely misunderstanding, going by the house metaphor.
<Zelphir>I wonder in what situation it is appropriate to use and what its effect is.
<spk121>the C version of it gets used to free memory in a function that can exit either normally or by throwing an error
<Zelphir>Ah hm.
<lechner>rekado: thanks for pointing it out! i had that a few days ago, too
***Noisytoot is now known as [