IRC channel logs

2022-10-20.log

back to list of logs

<old>lampilelo: There's a problem with the task stealing approach. Guile's continuation can only be restarted from the same thread
<old>So If you have to stop a computation, for example because a mutex is locked, then you have to capture the continuation and restart it later. Which could be on another thread
<old>Except if there's a way to capture continuation and restart it on another thread? But the documentation seems clear about it
<old>Oh well never mind. It works with prompts
<spk121>today, I've had Guile code that only works when compiled -O1 and not -O2, and C code that only works when compiled -O1 and not -O0. The coding gods hate me today
<lloda>the solution to that SO question is to use repl-option-set! not repl-default-option-set!. Obviously changing the default won't fix the current repl
<lloda>e.g. (repl-option-set! (car (fluid-ref *repl-stack*)) 'print p)
<lloda>ofc repl-option-set! is undocumented :-|
<lloda>daviid: that was just a rebase
<lloda>i think a proper patch should reuse the repl printer for exceptions (bc why should these printers be different?) and also do something with set-exception-printer! in boot-9 which works should be usable for this stuff and somehow it's not, because you need to replace each key (I think?)
<lloda>i'm sorry i'm not able to figure this out
<lloda>s/works should/should
<civodul>so we have this *cough* interesting memory leak in PID 1: https://issues.guix.gnu.org/58631#3
<civodul>i'm surprised to see more JIT code arenas being allocated, though that's not the biggest contribution
<civodul>has anyone attempted to write a conservative heap profiler?
<lloda>*repl-stack* isn't documented either. Shouldn't it be?
<lloda> https://www.gnu.org/software/guile/manual/html_node/REPL-Hooks.html#REPL-Hooks i guess
<lloda>well not quite. I've never used make-hook
***lampilelo_ is now known as lampilelo
<dsmith-work>{appropriate time} Greetings, Guilers
<sneek>Welcome back tohoyn
<dsmith-work>sneek: botsnack
<sneek>:)
<dsmith-work>!uptime
<sneek>I've been running for 8 days
<sneek>This system has been up 10 weeks, 2 days, 10 hours, 6 minutes
<vbramselaar>Hi there, is it possible to package a software application purely written in Guile pre-compiled? In a Debian package for example? So that, when running for the first time, there is no message about auto-compiling?
<rekado_>vbramselaar: yes, that’s how we distribute Guile packages in Guix.
<vbramselaar>rekado_: You got any pointers on how I can do it? Because currently the compiled files are in the users home folder en directly running them doesn't work I think?
<apteryx>a single match pattern cannot express a list of a single string, right?
<rekado_>vbramselaar: is this your own code? If so you should probably make some changes to the build system to make sure that the code is compiled and installed to a well-known location.
<apteryx>(a string which cannot be known in advance)
<dthompson>apteryx: (match thing (((? string? x)) x))
<dthompson>that would match a list with one arbitrary string in it
<apteryx>neat, thank you!
<dthompson>np!
<vbramselaar>rekado_: Yes my own code. what would be defined as a well-known location for Guile? I can only think of the home folder
<vbramselaar>I mean I can add stuff like GUILE_LOAD_COMPILED_PATH to point to the compiled files
<rekado_>vbramselaar: here’s an example Makefile.am: https://git.elephly.net/?p=software/guile-debbugs.git;a=blob;f=Makefile.am;h=b8f8b7d8f5afd1e38efb2fcbf88d5b64d382a965;hb=HEAD
<rekado_>it loads guile.am which defines rules to compile .scm to .go: https://git.elephly.net/?p=software/guile-debbugs.git;a=blob;f=guile.am;h=7bbd91b97f32ceecbf666d741313ff41407ae3b1;hb=HEAD
<vbramselaar>rekado_: I understand it now, I thought there was no system level ccache for compiled binaries
<vbramselaar>but there is
<cwebber>come hack Guile for your dayjob and change the future of the internet! https://spritely.institute/jobs/core-architect.html
<sneek>cwebber, you have 1 message!
<sneek>cwebber, mwette says: traps are used in guile for the debugger; I have done some work with them, see: https://github.com/mwette/guile-jtd
<cwebber>oh wow
<cwebber>sneek: later tell mwette oh wow thank you!
<sneek>Will do.
<daviid>cwebber: congrat for the job offer and expansion/extension of your intitute activities - this is great news for all schemers in general, and guilers in particular
<cwebber>daviid: thanks :)
<ArneBab>cwebber: good luck in finding a great candidate!
<cwebber>thanks ArneBab !
<old>Anybody has problem with displace-backtrace when COLUMNS is not defined in the environment?