IRC channel logs

2022-09-30.log

back to list of logs

***Furor is now known as LoupGris
***iyzsong-alt is now known as iyzsong
<manumanumanu>jeez. I have been so long without my computer I have forgotten how to use my emacs configuration, which has been unchanged since almost 10 years
<manumanumanu>So I have decided to move to a GUI client :)
<manumanumanu>Why are there form feed chars in boot-9.scm=
<manumanumanu>?
<manumanumanu>ah. GNU coding standards
<Arsen>yeah, form feeds are used to signify section breaks in source files
<Arsen>though, IIRC, they're falling out of favour nowadays
<lloda>they're useful to move around with C-x [ etc so i started using them myself after seeing them in the guile source
<lloda>the compiler should complain when you try to pass int as SCM :-\
***maximed is now known as antipode
***NullPointerErro1 is now known as NullPointerError
<sneek>dsmith-work: Greetings!!
<dsmith-work>Happy Friday, Guilers!!
<dsmith-work>sneek: botsnack
<sneek>:)
<dsmith-work>!uptime
<sneek>I've been running for one month and 22 days
<sneek>This system has been up 7 weeks, 3 days, 9 hours, 30 minutes
<sneek>Welcome back ArneBab!!
<Zelphir>daviid: Thanks for all the information. I store it in a text file for now. Still received your later messages : )
<daviid>Zelphir: welcome - sorry you are not willing to make these changes, the they would solve your problem
<Zelphir>Today at 1am was really not a good time to start ;) Today was work of course. Maybe I will do something in the future. I dealt with it by using `guile` in a normal terminal emulator, which does not have slowdown from long lines that much. But it would be cool to be able to improve things with the printer. Maybe I can manage to contribute something. My idea is, that I could go through all struct/record fields and linebreak after each and in case of
<Zelphir>list or alist, use existing pretty-print, to simply introduce more line breaks. But no idea yet, how to iterate through all struct/record fields. But if I remember correctly a struct/record is a vector internally?
<daviid>Zelphir: that would be the wrong way to solve the problem, you need to patch (ice-9 boot-9), that is a few line changes ...
<daviid>Zelphir: the patch is prposed by a guile expert, who has commit right ... don't loose your time trying to invent another solution, my 2c
<daviid>and just for the record, a 'normal' research lab image size is 20GB, saying that in a normal termnal it's ok is just ... well, ridiculous (no pun, but i doubt you are willig to read 20GB floats in a terminal ...
<daviid>ironically, the backtrace system in guile does truncate, because, said our maintainers, guile has 'very big sturctures', it would be ... to print those entirely ...
<Zelphir>I see : ) With "the patch" you mean what is described on the guile-cv page you linked to earlier, correct?
<Zelphir>I would usually not read 20GB of anything anywhere, to be honest xD I mean, that's way too many characters to read!
<daviid>Zelphir: these are the patch steps, but lloda used to have a real patch, theproblem, as usual, is that it lags behind when core guile is updated... hence i opted to describe the steps -
<Zelphir>Ah OK, makes sense.
<daviid>Zelphir: even displaying an icon size floats in a terminal would be ridiculous
<daviid>Zelphir: just find where the ice-9/boot-9.scm and go file are in guix, using (string-append (%package-data-dir) "/" (effective-version)) and (%library-dir), make a copy of ice-9/boot-9.scm, apply the changes 'manually', save, guild compile ... and install the go in (%library-dir) - then try here is a simple exampleof how it appears after the patch
<daviid>scheme@(guile-user)> (make-vector 1000 1.0)
<daviid>$18 = #(1.0 1.0 1.0 1.0 1.0 1.0 1.0 1.0 1.0 1.0 1.0 1.0 1.0 1.0 1.0 1.0 1.0 1.0 # …)
<daviid>Zelphir: ok, i am done with this conversation for now, but if you try and need help let us know ... good luck
<daviid>Zelphir: the above is a simple repl print, here is how an raised exception would appear.. you nedd to apply both recommendations in the guile-cv manual..
<daviid>scheme@(guile-user)> (error (make-vector 1000 1.0))
<daviid>ice-9/boot-9.scm:1686:16: In procedure raise-exception:
<daviid>#(1.0 1.0 1.0 1.0 1.0 1.0 1.0 1.0 1.0 1.0 1.0 1.0 1.0 1.0 1.0 1.0 1.0 1.0 1.0 1.0 1.0 1.0 1.0 1.0 …)
<daviid>
<daviid>Entering a new prompt. Type `,bt' for a backtrace or `,q' to continue.
<daviid>scheme@(guile-user) [1]>
<Zelphir>It's OK. If I need it, I can get to it. What I wonder though is, if this is such an easily solved problem, why should it only be solved for myself? Why not solve it for everyone, by trying to get a patch into standard Guile? Maybe I should rather try that instead of only looking out for myself. Not sure how realistic that idea is. Or why it hasn't been done already.
***maximed is now known as antipode
<daviid>Zelphir: you'd have to ask our maintainers, afaic, this should be fixed and have been fixed years ago ...
<old>If anybody is using Jami (telephony), there's now a libguile-jami.so that comes with it. It's not entirely completed but it's possbile to call your contacts from Guile for example.
<old>It's not currently mark for installation by the build system, but if there's any interest in that let me know.
<civodul>old: sounds fun :-)
<rekado>does anyone here know of a Guile port of a propagator library as presented in The Art of the Propagator?
<dthompson>rekado: uhhh future me might have one if you give me enough time to get to that chapter in "software design for flexibility"
<dthompson>I have not seen a guile implementation :(
<dthompson>maybe I should just skip right to that chapter...
<rekado>the paper comes with Scheme code, but that’s for MIT Scheme…?
<rekado>I got myself a copy of “software design for flexibility”, but while reading the introduction I remembered that I had some unfinished biology books to read…
<rekado>future me will not be pleased about the lack of progress.
<old>rekado: Awesome book. I've passed through it and it's really great. I you like biology, there's a cool comparison with software flexibiliy and cells IIRC after the intro
<rekado>I got to the comparison (I thought that was in the intro)
<old>Perhaps it is yes
<dthompson>rekado: yeah probably MIT scheme