IRC channel logs

2022-08-13.log

back to list of logs

<unmatched-paren>mwette: it doesn't make the error more descriptive, sadly
<unmatched-paren> https://paste.sr.ht/~unmatched-paren/eb87bcbdf8a0e01d24a22510edee22def2dc9ed1 <- this is my code; the my-program.sh is generated by the makefile
<mwette>maybe define (main . args) instead of (main args)
<unmatched-paren>mwette: Ohh! Thank you :)
<unmatched-paren>Hmm, it doesn't seem to help :(
<unmatched-paren>this is my config.mk, included into the makefile
<unmatched-paren> https://paste.sr.ht/~unmatched-paren/967c437d4dfddf0aa0b839f2620d70b2bda0cbaf
<unmatched-paren>are there any other flags i could add for extra debug info?
<mwette>you know cli.scm needs to be in a directory-called "my-program" and the parent of that needs to be in GUILE_LOAD_PATH ?
<mwette>also, the failed exception could be a bug in guile
<unmatched-paren>mwette: Yeah, I've got the directory structure down
<unmatched-paren>but isn't -L equivalent to prepending to GUILE_LOAD_PATH?
<mwette>and the LOAD_PATH ?
<unmatched-paren>and -C likewise for GUILE_LOAD_COMPILED_PATH?
<mwette>yes. that should do it
<unmatched-paren>i have those flags in the my-program.sh
<unmatched-paren>although that my-program.sh is the one generated when you install; the local one in the repo uses ${SRCDIR} instead of ${GSRCDIR}, and ${OUTDIR} instead of ${GOBJDIR}
<mwette>so I tried just using guile, and got that exception error. BTW I don't use getopt-long, guile maintainers recommend using srfi-37.
<unmatched-paren>mwette: Oh, really?
<unmatched-paren>I thought the ice-9 one would be recommended.
<unmatched-paren>srfi-37 seems a little overkill
<unmatched-paren>but i'll try using it
<mwette>with it you can do repeated flagged arguments
<mwette>I've gotten used to it --
<mwette>Do you need to raise (make-non-continuable-error) ? I'm not wise in the new exceptions
<mwette>&non-continuable => #<record-type ...> whereas (make-non-continuable-error) => #<&non-continuable>
<unmatched-paren>mwette: It's a stop-gap until i implement something to fill in that `else`
<unmatched-paren>so i can get the build system working first
<unmatched-paren>but thanks for the (make-non-continuable-error) tip :)
<unmatched-paren>hmm, i can't get args-fold to work https://paste.sr.ht/~unmatched-paren/19eb69838724987a45badf561a79f4798fd3860f
<unmatched-paren>it compiles and runs without errors, but nothing is printed
<unmatched-paren>ah, fixed it, but now it's not finding my modules
<unmatched-paren>what could this possibly mean? Unbound variable: #{\x7f;ELF\x2;\x1;\x1;\x0;\x0;\x0;\x0;\x0;\x0;\x0;\x0;\x0;\x2;\x0;>\x0;\x1;\x0;\x0;\x0;}#
<unmatched-paren>is it trying to load a guile object file as source...?
<unmatched-paren>Oh, it's... uh, trying to load /bin/sh as a Guile file.
<unmatched-paren>wut.
<unmatched-paren> https://paste.sr.ht/~unmatched-paren/a0fd6e8afa6462951d499bedc8e664118396cd86 this is the make rule that's generating the guile script
<unmatched-paren>i think it might be expanding ${0} to /bin/sh
<unmatched-paren>but why?
<unmatched-paren>i thought that would expand to the script's name, not the shell's
<unmatched-paren>i'll replace $${0} with ${@} i guess
<unmatched-paren>itworks :)
<tohoyn>are guile keywords quaranteed to be disjoint from other base types?
<lilyp>if by "keywords" you mean #:this, then yes, they're distinct from strings or symbols
<lilyp>I'm pretty sure deep down it's just one bit or something like that, but there you go
<tohoyn>tx