IRC channel logs

2022-08-03.log

back to list of logs

<wingo>got a generational collection working in whippet, in a way that allows (but does not require) conservative root-finding as in bdw-gc
<civodul>wingo: wo0t! sounds like it's getting serious :-)
<wingo>yeah :)
<drakonis> https://code.thintz.com/3l/
<drakonis> https://3lproject.org/
<tohoyn_>sneek: botsnack
<sneek>:)
<drakonis>so, how exactly would i proceed with transitioning kernel to scheme?
<drakonis>rather
<drakonis>scheme to kernel inside guile?
<dthompson>hmmm guile doesn't seem to optimize away multiplications by zero.
<dthompson>I ran a little test: ,x (lambda (x) (+ (* x 0) x))
<dthompson>I guess guile could only optimize it away if it knew that x was a number.
<drakonis>types?!
<dthompson>this even more contrived example generates bytecode that eliminates the math: ,x (lambda (x) (let ((y 3)) (+ (* y 0) y)))
<dthompson>so nvm, guile will do the right thing if it knows
<drakonis>it needs ways to know
<lilyp>tbf you can do operator overloading with goops
<lilyp>so i could define my own record type for which (* x 0) yields 1
<dthompson>lilyp: yeah but at compile time guile knows if it's dealing with primitive math operators or not
<dthompson>there's lots of math optimizations that are happening that wouldn't be possible otherwise
<ArneBab>wingo: wow — nice!
*dthompson goes to find the channel logs
<dthompson>oh wow! nice indeed! a new gc is very exciting
<ArneBab>Sidenote: Some weeks ago I offered that I could review and merge simple compatibility patches if I could get commit access but didn’t see replies. My goal is to avoid frustration of contributors who provide boring-and-simple-and-useful improvements. Did I miss something? Whom should I ask to move forward?
<civodul>ArneBab: howdy! i didn't see your earlier request, but what you suggest sounds good to me
<civodul>like you write, merging the boring-and-simple-and-useful patches quickly enough would be great for everyone
<civodul>so unless wingo disagrees, let's do that :-)
<civodul>and of course you're welcome to ask for guidance on IRC, esp. at the beginning
<civodul>sounds good?
<ArneBab>civodul: sounds good! Thank you! (and high five for persistence! :-) — I know how easy it is to miss stuff myself …)