IRC channel logs

2022-08-01.log

back to list of logs

<AwesomeAdam54321>How can I use ice-9 open-pipe* to run a subprocess and capture it's output? I can't find any examples online
<iyzsong>AwesomeAdam54321: hey, in the source of guix, there are many examples
<AwesomeAdam54321>iyzsong: Thanks
<AwesomeAdam54321>What is allowed as datums in a case statement?
<AwesomeAdam54321>I get an invalid clause error when I try to use strings for datums
<daviid>AwesomeAdam54321: symbols and numbers
<AwesomeAdam54321>daviid: How could I do a case statement with strings? or would I just have to use when statements?
<daviid>use string->symbol
<daviid>(case (string->symbol "hello") ((hello) "world"))
<flatwhatson>AwesomeAdam54321: not when statements, probably a cond
<flatwhatson>(cond ((equal? val "hello") "world"))
<AwesomeAdam54321>daviid: Is there a reason case statements only accept symbols and numbers?
<daviid>AwesomeAdam54321: did you read the case statement in the guile manual?
<daviid>or ny scheme manual
<daviid>any
<AwesomeAdam54321>daviid: I read the guile manual online, but I didn't know what a datum exactly was from looking at it
<daviid>ok, it says First, key is evaluated. The result of this evaluation is compared against all datum values using eqv?.
<daviid>strings can't be compared using eqv?
<AwesomeAdam54321>my mistake
<daviid>no problem, it's kind of a faq, soyou're not alone :)
***karlosz_ is now known as karlosz
***rgherdt_ is now known as rgherdt
***Furor is now known as Colere
***pkill9_ is now known as pkill9
***civodul` is now known as civodul
<dsmith-work>{appropriate time} Greetings, Guilers
***chris is now known as Guest9620
<lloda>guile doesn't check for gperf at configure time
<daviid>lloda: i thought one of us fixed that, i even thought it was you? :) but i think there is a patch somewhere, not sure
<daviid>hum, maybe i am wrong, i can't find any trace of any gperf/configure recent discussion(s) in user/devel ml ... and our channels logs aren't searchable at the moment
<cwebber>hello hello
<cwebber>a thought:
<cwebber>I've recently discovered just how extremely much (default-optimization-level 1) makes debugging guile code easier
<cwebber>I'm just thinking out loud...
<cwebber>I wonder if it would be a good idea to add a config flag to my ppackage
<cwebber>so i could do ./configure --debugable or something
<cwebber>andm aybe it would compile using the -O 1 flag
<Zambyte>Hi, I'm trying to play around with some portable libraries, but I'm having trouble. For a test I'm trying to run SRFI-78 from chez-srfi, which has a compat.guile.sls file, but won't load for me. This gives a "no code found for module (srfi srfi-78)" error for me, not sure why or what to do differently: `git clone https://github.com/arcfide/chez-srfi srfi && GUILE_LOAD_PATH="$PWD:$GUILE_LOAD_PATH" guile -c "(import (srfi :78))"`. Anyone
<Zambyte>have any suggestions?
<Zambyte>I've also tried with `-x .sls` on guile, no luck
<jab>cwebber: how do you debug guile programs? Debugging elisp programs is awesome in comparison (my opinion)
<flatwhatson>jab: there's a full set of tracing & breakpoint tools available in the guile repl
<flatwhatson>plus the `pk' function is very useful to hack in some "printf" debugging
<flatwhatson>but as with C, the optimizer might inline stuff which makes stepping through your program less useful
<flatwhatson>some better emacs integration would be nice
<dsmith-work>flatwhatson: Have you tried geiser? (Note: haven't used it in a while)
<dsmith-work>sneek: geiser?
<sneek>I could be wrong, but geiser is git clone http://git.hacks-galore.org/jao/geiser.git
<dsmith-work>Awww.
<jao>sneek is very wrong
<dsmith-work>sneek: geiser?
<sneek>geiser is git clone http://git.hacks-galore.org/jao/geiser.git
<jao>that's ancient
<dsmith-work>sneek: forget geiser
<sneek>Okay.
<dsmith-work>sneek: geiser?
<jao> http://geiser.nongnu.org would be a good starting point
<jao>(sorry, i don't know how to talk to sneek :)
<dsmith-work>sneek: gaiser is http://geiser.nongnu.org
<sneek>Got it.
<dsmith-work>goodbot
<dsmith-work>sneek: geiser?
<daviid>gaiser?
<dsmith-work>Bah!
<daviid>:)
<dsmith-work>sneek: forget gaiser
<sneek>Consider it forgotten.
<dsmith-work>sneek: geiser is http://geiser.nongnu.org
<sneek>So noted.
<jao>dsmith-work, thanks
<dsmith-work>I have relatives with the name "Gaiser". Finger memory. Sorry
<jao>oh, is it a given name?
<dsmith-work>Last name
<jao>aha, never heard of it!
<dsmith-work> https://www.linkedin.com/in/briangaiser/
<dsmith-work>My brother-in-law
<civodul>hey, bona nit jao :-)
<civodul>& howdy dsmith-work
*dsmith-work waves
<jao>civodul, bonsoir :)
***theruran_ is now known as theruran
***alanz_ is now known as alanz
***conjunctive_ is now known as conjunctive
<civodul>jao: long time no see!
<civodul>still hacking the good hack?
<jao>for some value of good hack, yes :)
<jao>how about you?
<flatwhatson>i do use geiser, but i haven't mastered its debugger integration
<flatwhatson>something went haywire with my setup and i've procrastinated on fixing it...
<flatwhatson>readline and completion support in the repl is bearable enough to be productive