IRC channel logs

2022-06-30.log

back to list of logs

<trevdev>I acciently created a never-ending recursion, cause by the fact that I passed un-evaluated symbolic lists into the recursive function which expected evaluated lists. This is fine, I but I would like to know how the recursion ocurred rather than an error
<trevdev>I'm wondering if anyone would be willing to look at my mistake
<trevdev> https://pastebin.com/T2NxdWjK
<pinoaffe>trevdev: keep in mind that if you call nm-test-bad with any argument of the shape ((...) ....), it will again call nm-test-bad with an argument of said same shape
<pinoaffe>trevdev: furthermore, since nm-test-bad is tail recursive, it won't exhaust the stack depth
<pinoaffe>so no errors occur and it'll just keep on recursing
***attila_lendvai_ is now known as attila_lendvai
<dsmith-work>Morning Greetings, Guilers
<lilyp>trevdev: (nm-test '((caar terms) . (cdr terms))) passes '((caar terms) . (cdr terms)) literally rather than decomposing terms
<tohoyn>trevdev: maybe you should use (nm-test `(,(caar terms) . ,(cdr terms)))
<tohoyn>trevdev: You already had it there
***lilyp_ is now known as lilyp
<cwebber>meep