IRC channel logs

2022-06-06.log

back to list of logs

<mwette>lechner: sometimes helps to compile w/o optimization: guild compile -O0 file.scm
<mwette>also, maybe useful: github.com/mwette/guile-jtd
<stis>Hello guilers!
<sneek>wb chrislck!
***chris is now known as Guest2809
<tribals>Hi, folks!
<tribals>I'm wondering: what is the preferred way to handle URLs (as data) in Guile? Common examples: I've a "base" url which doesn't change, but want to produce concrete urls from that base & relative part (constructed programmatically). I've looked at `(web uri)` but can't figure out how to use it for that kind of task?
<tribals>May be related: as I'm reading guile code (mostly guix), I see it is common to handle urls as string, eg. by constructing paths with `(string-append ...)` etc. I see same pattern used for constructing file paths, too. Isn't it too dangerous? Paths in general is very tough topic on its own. Is there any "reliable" way to handle paths?
***Guest2809 is now known as chrislck
<lechner>Hi, how may I pass a void pointer by reference to the FFI function in line 39, please? Plus, how do I read the result? https://paste.debian.net/1243158
<lampilelo>lechner: if it's an output parameter you can do: (bytevector->pointer (make-bytevector (sizeof '*) 0)), then you can dereference-pointer
<lechner>lampilelo: thank you!