IRC channel logs

2022-04-19.log

back to list of logs

<daviid> do you write (match exp (#f 'false) (a-thing 'a-thing)) or in the other order, in your own code?
<daviid>ok, goops has an example and uses the way i wrote above, just curious, because it seems both works, although the manual says 'identifier anything, and binds identifier', but then it is anything but #f i guess
<lilyp>daviid: #f is not an identifier
<lilyp>neither would 'identifier be
<lilyp>an identifier would be an unadorned symbol
<daviid>but if you change the order, the identifier can 'receive anything' would bind to #f?
<daviid>lilyp: if you write (match exp (a-thing 'a-thing) (#f 'false)), and exp revalueates to #f. i was indoubt what would happen ...
<lilyp>that's the point, no?
<lilyp>this is like C++ exceptions: specific exceptions go to the top, generic ones go down
<daviid>right, i miss evaluated my own example, and wrongly thought i could (i wouldn't, i was just curious) invert the order, unlike the manal said, but i was wrong, asked, then solved my question .. and the manual is correct
<lilyp>happy to help
<daviid>tohoyn: ping
<tohoyn>daviid: awake
<daviid>tohoyn: i pushed a series of very important patches, nothing user visible, but g-golf core restructuring that might influence your work
<daviid>all on the devel branch - couldyou whentimes allow, grab the latest devel, read the commit logs, adapt if necessary (as you use some g-golf core stuff i think) and no mater what report problems ..
<tohoyn>I'll check that
<daviid>tohoyn: ok
***chris is now known as Guest9733
***Guest9733 is now known as chrislck
<manumanumanu>Long time no see!
<chrislck>sneek: botsnack
<sneek>:)
***chris is now known as Guest267
***yewscion10 is now known as yewscion
<stis>Tja guilers!
<stis>My new blog address: itampe.com
<stis>lost some articles in a computer crash, but oh well nothing important
<stis>Also tho host stoped us from using ssh and had to manually upload all files. A real pain.
<stis>Now I just write the md file and uploads it via a make command
<stis>I'm using pelican as a static site generator
<stis>(python)
<civodul>wingo: hi! what are your things on lightening RISC-V support? https://gitlab.com/wingo/lightening/-/merge_requests/14
<civodul>it seems to be ready, would be nice to merge for the next Guile release
<civodul>(i'm incompetent on these matters though :-))
***Guest8410 is now known as roptat
<tricon>The more I work with Guile, the more convinced I am that the only programming languages I need in my life are: Guile, C, and Emacs Lisp.
<stis>yep, even teh soft side of us can unoy scheme ;-) http://itampe.com/category/poems.html
<stis>I will try to write a little about my hastable implementation and some about the one shot continuations as well now when I have a sane process to blog again
<stis>My old provider raised the price dramatically and took away the ssh/scp option. I'm on AWS now
<tricon>stis: have you gotten into Gemini at all? i've been thinking of starting a microblog served by it.
<stis>tricon: no, I use static pages and upload them via scp using make
<stis>the static generator is called pelican (python=
<tricon>stis: you just answered my next question. thank ya.
<stis>I want syntax highlightening for many languages and math.
<stis>love makdown
<stis>markdown
<stis>I just hate that all social apps we have at work sucks with content generation. No math, no computer lang supprt
<stis>no markup, just the old madness. I bet that when math arrives it will be equation editor and ugly typesetting
<stis>fro ages, when proper handling of math was solved in the 80ies wit TeX
<tricon>truth.
<daviid>stis: nice, but outof curiosity, why not haunt though? with such a level of knowledge you have in scheme, it can't be because it was 'too difficult', so what is missing in haunt that pelican offers? or is it something else maybe ...
<stis>I do not know how it supports syntax highlightening and math, simply that.Maybe I shoulud try haunt
<stis>I'm not good at html generation and web technology that is needed to hand roll everyting from scratch
<stis>daviid: ^^
<daviid>stis: it would be nice to try, and maybe you can help to improve it - the math rendering is missing in haunt (i think), but according to its own website, which shows some highlited scheme code, it must support code highlithing one way or another, maybe preprocessing, not sure
<daviid>stis: but html is generated for you by haunt, you only need to write sxml code
<stis>well I want syntax highlightening for C,bash,python,guile,prolog,C++
<daviid>and a builder if you don1t like the built-in haunt builder
<stis>wel for math you need to know how to link the latex markup to get it rendered. But if I would do that I would read the python code and copy it.
<stis>Maybe I can get it to work via python on guile (the syntax highlighter)
<stis>anto get more languages highlighted
<stis>so many things I need to do.
<stis>I plan to blog a little about the recent hashtable implementation I did and also the one shot continuations that dramatically increased the perfromance of the python-on-guiles generator implementation (faster than python)
<stis>then I want to explore these one shot generators for improving prolog programs
<stis>and see if things improve
<stis>also nice to see if one shot generators can improve fibers performance
<stis>sorry one shot continuations
<stis>daviid: ^^
<daviid>stis: sure, too busy ...
<stis>But I agree with you that we should have a scheme solution, sxml is a wonderful superpower
<daviid>langs highlighters probably exist as free s/w somewhere, maybe not in scheme, i wonder how difficult it would be to plugone to haunt ...
<stis>This is a nice task to give someone who wants a project to learn scheme
<daviid>what about math rendering, is it static as well, or js based and dynamic? on pelican imen
<daviid>*mean
<stis>daviid: I think pelican use some server that translate all the math, not sure, can also be mathml, I really do not know the tech
<stis> http://itampe.com/a-deep-question.html
<stis>this is how it looks
<stis><div class="math">$$
<stis>v = \frac{\hbar}{m_e r}.
<stis>$$</div>
<stis>is one looks at the html source
<stis>MathJax
<stis> https://www.mathjax.org/
<stis>so it is linking in that code to the page
<stis>someone with some html fuu can probably quite quickly copy the approach
<stis>daviid: ^^
<stis>probabluy ok to use strings in sxml to transfer the math and a (math ...) tag
<stis>that get's transformed correctly and some magic to link in the javascript needed
<daviid>stis: ok, tx
<stis>daviid: https://pygments.org/
<stis>I can spend the night to see if I can run it under python-on-guile
<stis>if so it's available for haunt
<stis>quite a lot of work is in that project
<daviid>stis: i didn't mean to 'pressure' you, i was just curious why not haunt :)
<stis>Can be fun to see if I can compile it.
<stis>aja, I'm experementing with python on guile, forgot that. But I put up a build environment for pygmnets. enough playing now.
<stis>531 langs supprted, wow!