IRC channel logs

2022-03-27.log

back to list of logs

<daviid>tohoyn: hello - everything you mentionned in your wish list will, in the end, be implemented, but my highest priority now is full support for callback
<daviid>tohoyn: in order to do this, i have (had to) to reorganize some of the g-golf core functionality, which is what i am on now
<daviid>tohoyn: doing so, i also spoted a couple of things that needed to be improved, notably user customization, which due to guile-3.0, can't be handled bytop-level variables anymore... this has a few implications for you, i am not finished with tose changes, almst, but you may already adapt for the two changes i made and documented in the manaul, all in the devel branch
<daviid>tohoyn: i updated the online manual as well - the changes youneed to adapt,sofar,are (1) GI Strip Boolean Result and GI Method Short Name Skip, all documanted in https://www.gnu.org/software/g-golf/manual/html_node/Customization-Square.html - so, instead of setting the 'old' %gi-strip-boolean-result and %gi-method-short-name-skip, you need to use their respective interfaces, described in the above manual link ...
<daviid>tohoyn: let meknow if you have any quiz .. and if everything is ok after you changed your code ...
<daviid>tohoyn: incidentally, i also made two (user invisible) changes that boosted g-golf import namespace by13%, which is always nice to get :)
<spk121>daviid: how's g-golf doing these days? Is it ready to go?
<daviid>spk121: it's in good shape, every day better, but still lacks a couple of features to be 'fully ready to go'
<spk121>nice
<tohoyn>daviid: if I have imported a GI function is there any way to find out if it is subject to boolean result stripping or not?
<tohoyn>daviid: I mean that it makes sense to apply boolean result stripping to the function
<tohoyn>daviid: is it necessary and sufficient to check that result-type = boolean and n-gi-arg-out >= 1 in the function descriptor?
<tohoyn>daviid: or must we have n-gi-arg-out = 1 ?
<lilyp>what is n-gi-arg-out? Does the boolean return value count towards it?
<lilyp>If not, then any nonzero value means that you're missing an output argument if you only check the first result
<lilyp>(note: I'm assuming G-Golf translates output pointers to values in the same manner as Guile-GI here)
<tohoyn>lilyp: n-gi-arg-out is the number of output variables. AFAIK the boolean return value is not counted.
<lilyp>okay, and what'd be boolean result stripping? returning output values rather than the boolean result?
<tohoyn>lilyp: the point is that the boolean result type #f means that the procedure has failed. when the boolean result value is stripped an exception is raised on failure.
<lilyp>ahh, this is for the hl-api, right?
<tohoyn>yes
<stis>Hello guilers!
<mwette>wingo: unwanted source issue bug #54478 updated: passing src to make-seq near line 1619 in ice-9/psyntax.scm
<tohoyn>suppose that myproc returns multiple values. is there a better way to compute its result to a list than (call-with-values (myproc ...) (lambda args args))?
<tohoyn>s/compute/convert/g
<rlb>tohoyn: perhaps receive?
<rlb>scheme@(guile-user)> (use-modules (ice-9 receive))
<rlb>scheme@(guile-user)> (receive vals (values 1 2 3) vals)
<rlb>$2 = (1 2 3)
<rlb>
<rlb>depending on what you need
<rlb>(or perhaps srfi-11)
***sneek_ is now known as sneek
<daviid>tohoyn: no, as stated in themanual, there no automatic way, hence itis a user reponsibility, and there is an example in themanual as well ...
<daviid>tohoyn: remember that those g-golf internals, n-gi-arg-out for example, you are not supposed to use, doing so is at your entire own risk - in thisparticular case, it would definitely notbe sufficient
<daviid>lilyp: one of the g-golf core directory is named hl-api (for 'historical' reasons so to speak), but nothing in there, unless published in the manual, should be used - just a remindder, for all g-golf users