IRC channel logs

2022-02-24.log

back to list of logs

<vijaymarupudi>devmsv: Same, SICP did not require too much math, and you could skip the mathy parts if you wanted.
<vijaymarupudi>I've been meaning to learn more about Guile's implementation and contribute more to it, but so far my patches have not received any comments by a maintainer so motivation to do more is a bit hard to find.
<vijaymarupudi>Is there anything that I (or the community) can do to help get the patches in? I have a typo fix for example that shouldn't take more than a minute to review.
<vijaymarupudi>I understand that the maintainers are busy, want to see what can be done to lighten the workload for them
<sneek>chrislck: wb
<chrislck>sneek: botsnack
<sneek>:)
<devmsv>Thanks you everyone will try with SICP then. Hope I can become decent programmer one day and contribute to the community
<ArneBab>drakonis: the little Schemer is really great — mind-opening and fun to read; and it made recursion natural for me.
<ArneBab>devmsv: the little Schemer is really great — mind-opening and fun to read; and it made recursion natural for me.
<devmsv>ArneBab: thanks. I found this review of sicp where they mention it: https://medium.com/@imslavko/sicp-and-me-d3a720c8dab6 so it seems a good complement
<trofi>it's probably worth getting some algorithmic background as well. like "INTRODUCTION TO ALGORITHMS CORMEN 3RD EDITION"
<opticblast>What's the best way to manage a Guile project with multiple files and dependencies?
<opticblast>For example, in Haskell I would use cabal (installed with ghcup), and in Rust I would use cargo (installed with rustup)
<pinoaffe>opticblast: guix!
<robin>there's also guildhall -- though tbh i've never used it myself, because guix exists :P -- which may be more similar to language-specific package managers like cabal
<pinoaffe>guildhall is also fairly stagnant as far as I can tell
<dsmith-work>Hey Hi Howdy, Guilers
<stis>Tjaba guilers!, Hi dsmith-work!
*dsmith-work waves
<manumanumanu>Hi, stis!
<manumanumanu>I haven't been online in about 200000 years.
<manumanumanu>nice work with the hashtable stuff
<manumanumanu>but why goops? That kind of indirection adds upp with regards to performance
<manumanumanu>in tight loops and such
<manumanumanu>oooh.. it is for python-on-guile?
<stis>manumanumanu: there are tricks to get goops performant in tight loops
***skapata is now known as Guest4571
***skapate is now known as skapata
<stis>yes thats my current target (python-on-guile)
<manumanumanu>stis: like (get-accessor thing) and (get-mutator thing)?
<stis>well I calculate the dipsatch function for a application beforehand, so basically you get the raw fucntion for a class regarding amethod
<stis>so essentially one con choose to use goops or not when you define it using goops, so there is no essential loss.
<stis>but no inlining
<stis>I am trying to get it alive now, debugging ,,,¨
<manumanumanu>sounds like frustration and fun :)
<stis>it's quite exciting