IRC channel logs

2022-01-25.log

back to list of logs

<stis>hi guilers
<drakonis>hi
***yewscion91 is now known as yewscion
<dsmith-work>UGT Greetings, Guilers
<civodul>hey wingo
<civodul>wingo: i tried the following "benchmark" to compare memory usage and performance of "main" vs 3.0.7:
<civodul>./pre-inst-env time -f '%U seconds\n%M KiB' guile -c '(use-modules (system base compile)) (compile-file "gnu/packages/crates-io.scm" #:optimization-level 1)'
<civodul>"main" is ~10% slower and peaks ~2% higher (resident memory)
<civodul>i think that's a relevant bench because the compiler resorts to lots of bignums
<civodul>because it's a very large file with lots of top-level defines
<civodul>ah but the good news is that this one performs better in "main" than 3.0.7:
<civodul>./pre-inst-env time -f '%U seconds\n%M KiB' /data/src/guile-3.0/meta/guile -c '(use-modules (system base compile)) (compile-file "gnu/packages/crates-io.scm" #:optimization-level 1 #:opts (list #:inlinable-exports? #f #:resolve-free-vars? #f))
<civodul>~5% faster and a bit less memory
<civodul>phfew
<civodul>~~~
<civodul>now that read-syntax annotates syntax objects directly...
<civodul>is decorate-source in psyntax still useful?
<civodul>looks like it, hmm