IRC channel logs

2022-01-22.log

back to list of logs

<haugh[m]>Guilers, does anyone use Artanis? It looks like a simple and intuitive MVC but I can't find much of a community.
<drakonis>haugh[m]: best to kick one off then!
<lilyp>well, there is the SZDIY community if you read chinese
<lilyp>though their IRC still links to Freenode, so maybe they're dead
<lilyp>interestingly, it's not used in mumi, which instead uses a different web helper library: https://notabug.org/cwebber/guile-webutils
<drakonis>have you tried joining the same channel in libera?
<haugh[m]>it's dead
<drakonis>i see
<drakonis>perhaps it is time to kick off a community then.
<drakonis>i want to play with artanis once i have time for it
<xiews>The mailing list is active for artanis.
<xiews>It is production level.
<chrislck>sneek: botsnack
<sneek>:)
<sneek>Yey! chrislck is back
<chrislck>sneek: botsnack
<sneek>:)
<ArneBab>sneek likes chrislck ☺
<bsima>i'm trying to do (map <accessor> '(<obj> <obj>)) but I keep getting this error "No applicable method for <accessor>", but (<accessor> <obj>) works just fine...
<bsima>is there something about accessors in GOOPS that make them not mappable? I thought they were just functions
<bsima>hm, (<accessor> (car '(<obj> <obj>))) also throws the same error
<mwette>does (apply <accessor> (list <obj>)) work?
<bsima>no it does not
<mwette>maybe map uses apply
<bsima>wrapping it in a lambda doesn't work either
<bsima>damn, my list of <obj> was quoted wrong, so accessor was getting symbols instead of objs
<mwette>You may need to define a map that works on one list: (define (map1 fn ls) (let loop ((rz '()) (ls ls)) (if (null? ls) (reverse rz) (loop (cons (fn (car ls)) rz) (cdr ls)))))
<lilyp>nah, apply is well-defined for accessors
<lilyp>or functions in general :)
<lilyp>(apply fn x) = (fn x1 x2 ...) always
<spk121>Say I have a module A that includes module B, and I want to re-export the public interface of B in A. Is there a way to do that programmatically without having to list each procedure in the define-module #:re-export ?
<lilyp>spk121: iterate over the obarray of its public interface
<spk121>True. module-obarray isn't documented, but, there doesn't seem to be a documented way to do that sort of module system reflection.
<daviid>spk121: re-export-public-interface in g-golf [andall the projects i work on, snarfed from guile-gnome ...] https://git.savannah.gnu.org/cgit/g-golf.git/tree/g-golf/support/module.scm
<daviid>spk121: you need guile 2.0, 2.2 or >= 3.0.7 - which fixed a long awaiting module-use! reported bug ...
<spk121>daviid: thank you
<daviid>welcome!