IRC channel logs

2022-01-11.log

back to list of logs

<rlb>wingo: oh, and should I be testing main or something else?
<rlb>wingo: won't be surprised if this indicates something not quite right in lokke's compiler/compilation, but here's how a build using current main fails: https://paste.debian.net/hidden/ca3f7b22/
<rlb>And if it is being caused by inlining, if there's a way to "opt out" for some files, then that might work for now too...
***Guest2835 is now known as roptat
<dadinn>I am trying to figure out how to fetch something with http-get and pipe it as input into a process. I can see that (web client) http-get has a #:stream property, but not sure how to do this piping with the ports :/
<dadinn>also, I am getting an error using guile-3.0 that call-with-port procedure is not found :/
<dadinn>also, it I am using guile-3.0 and it seems that some gnutls module is missing for (web client) module to work!
<dadinn>I am on Debian Bullseye, the guile-gnutls package seems to depend on guile-2.2
<dsmith-work>UGT Greetings, Guilers
<dsmith-work>wingo: Sill around? Lightening needs some love.
<dsmith-work>The ->size in the literal_pool is never initally set. Bad things can happen if the allocator doesn't clear memory.
<wingo>i saw your mails!
<wingo>dsmith-work: good catch
<wingo>scm_gc_malloc will zero it tho, fyi
<wingo>which is how it's used in guile
<dsmith-work>Yes, but.
<wingo>will poke later this evening
<dsmith-work>Someone is using it independenlty with a different non-zeroing allocator.
<dsmith-work>Also, the default-if-unspecified allocator is malloc
<dsmith-work>I think the tests don't specify an allocator.
<dsmith-work>wingo: Thanks for taking a poke at it.
<dsmith-work>Luke Nihlen is who is getting the segfaults.
<tohoyn>daviid: method hash of interface <g-icon> has void as its argument type. is this ok?
<tohoyn>daviid: procedure gi-function-info-is-method? returns #f for methods deserialize, hash, and new_for_string of <g-icon> but #t for other methods of <g-icon>. is there something wrong here?
<daviid>tohoyn: right in the front page of the GIcon, manual, these are functions, not methods
<daviid>have to go afk, bb much later ...
***roptat is now known as Guest4659
<wingo>lloda: wdyt about merging wip-inline-digits
<wingo>i am thinking yes
<wingo>unrelatedly -- i finally got to see some assembly from chez scheme recently and am thinking about how to close the gap
<dsmith-work>Ahh. cool.
<wingo>for fib, we basically need to reduce the instruction count to 1/3 of what we have. there are quite a number of things to do but it seems quite doable
<wingo>for a 3.2 tho
<wingo>3 things i would like for 3.2 -- utf-8 strings, a more register-like vm (fixed set of registers instead of stack-operands-as-registers thing that we do now), and a better gc. probably the gc will slip tho
<wingo>with more register-like vm the idea would be that you could do proper register allocation over all code at compile-time, and jit-time you would have less overhead to load/save operands from the stack, and have smaller stack frames
<dsmith-work>Oh, and compile to a single-file executable binary...
<wingo>that would be nice wouldn't it!
<dsmith-work>heh
<wingo>i guess there is also webassembly too
<wingo>humm, lots of things, not enough time :P
<dsmith-work>wingo: BTW: Thanks again for all your efforts! Not enough time indeed!
<lilyp>we'll have to cut corners, so well' only compile to a single file web assembly :)
<wingo>:)
*wingo grumbles about icecat vs gitlab
<dsmith-work>icecat? what what the Debian flavor?
<dsmith-work>Iceweasel ?
<wingo>i am on guix, whatever the firefox is called there
<wingo>had to override the UA in order to re-log-in to gitlab
<dsmith-work>Heh. There is/was a BurningDog too.
<lilyp>TemperatureIndicatorAnimal > Brave
<dsmith-work>lol (really!)
*sneek giggles
<lloda>wingo: wip-inline-digits looks great from here