IRC channel logs

2022-01-09.log

back to list of logs

<Wezl>does anyone know of a vim plugin for guile or scheme that doesn't break when you type a pipe and supports #{}# syntax?
<lilyp>I think the Guix manual mentions one, note (guix)G-Expressions, but it's not so much a plugin as in an entire editor.
<tohoyn>sneek: botsnack
<sneek>:)
<sneek>Welcome back tohoyn
<dsmith>Wezl: Sorry. Most Guilers are emacs-heads, methinks.
<mwette>I want to drain a vec in reverse order: repeately pop and do something with the returned (u8) value. What's a clean way to do this?
<mwette>^ actually returned Some(u8) value, I guess, until I hit None
<mwette>oops: wrong channel
<tohoyn>daviid: is it so that when the g-golf-callback-closure interface is ready it can be used to create callbacks from guile procedures, which can be passed to e.g. gtk-callback-action-new?
<dsmith>mwette: Getting a bit "Rusty" there?
<mwette>dsmith: Yes, sir. Wanted to learn it. I'm generating a parser for "mlang" based on tables generated by nyacc, and the lex'er functions.
<dsmith>I am currently furiously digging rust. The more I understand it, the more I like it. It's almost like an addicting drug or something.
<dsmith>mwette: `for value in the_vec.into_iter().rev() { ... }` will supply values to the block in reverse order as well as emptying the_vec. You can't access the_vec after that.
<mwette>dsmith: I don't want the vec after. I'm pushing char reads back into the input buffer after char-sequence is rejected.
<dmiles_afk> https://github.com/opencog/atomspace/blob/master/examples/atomspace/gperf.scm#L2 <- guile accepts this escaping?
<wingo>dmiles_afk: yep
<dmiles_afk>ok awesome
<dmiles_afk>a few years ago stis has a GC patch for guile for his guilelog.. is that patch still realivant?
<dmiles_afk>stis = Stefan Israelsson Tampe
<dmiles_afk>guess the question is easier if posed.. as did a guy named Stefan Israelsson Tampe mention a problem with Guile's GC that eventual got fixed?
<daviid>sneek: later tell tohoyn yes, i am working on it - paused to fixed the bugs you reported - noeta, but working on it with ahigh priority ...
<sneek>Got it.
<daviid>* no eta ...
***roptat is now known as Guest2835
<wingo>dmiles_afk: hard to know. if debbugs entry is open it is likely to still be relevant