IRC channel logs

2021-12-25.log

back to list of logs

***taylan2 is now known as taylan
<mala>ArneBab, have you thought much about how wisp could work with Common Lisp? any gotchas that I should be considering? I don't know CL well, but it seems like the only challenge would be if ":" had a special meaning within it
<tohoyn>daviid: g-golf gives a warning about missing library in debian: https://paste.debian.net/1224702
<daviid>tohoyn: never heard of libharfbuzz-gobject, and you'd have to check with debian
<daviid>though, i am on/using debian as well, i do not have this 'bug'
<daviid>i see it is installed here, i guess automatically as a 'debian' dependency 'hell', but g-golf only depends on what is listed in the manual and checked by the configure steps...
<daviid>tohoyn: it seems it is a pango 'indirect dependency', that 'hell1' comes because of gtk, not because of g-golf
<daviid>anyway, it should have been installed automatically, my giuess is you have a 'corrupted' debian installation on that side
<tohoyn>daviid: do you use debian testing or stable?
<daviid>testing
<daviid>stable doesn't have gtk4
<daviid>g-golf works perfectly well on stable of course, but i need gtk4 ... [among other none g-golf related needs that are on testing only ...]
<tohoyn>daviid: here is a new snippet: https://paste.debian.net/1224703/
<tohoyn>daviid: and here is its output: https://paste.debian.net/1224704/
<tohoyn>daviid: the output between "**1**" and the critical warning is my own debugging code
<tohoyn>daviid: so the critical warning is essential here
<daviid>tohoyn: ok, will look into it, but after i fix your earlier post and another thing i was working on ... gona take a few days... tx for the snipset
<tohoyn>daviid: I ran the snipset on Ubuntu 21.10
<tohoyn>daviid: but I have installed Guile 3.0.7 on it
<fnstudio_>sorry, this is really hash table 101, but is there any performance drawback in using large structures as keys in a ht?
<lilyp>depends how you calc your hash
<lilyp>if you do a deep hash calc every time, then sure, if you just hash some pointer then no
<fnstudio_>just meaning to use the make-hash-table default
<fnstudio_>oh ok, thanks, if i use a large list, i suppose by default i'm just passing a pointer to the large list?
<lilyp>hash is definitely slower than hashq
<fnstudio_>oh ok, that makes sense
<fnstudio_>thanks
<jpoiret>how do names from eg boot-9 get resolved? I'm looking at the module system, and (module-bound? (current-module) 'make-module) is #f, but you can obviously use it. Is there anywhere I could understand this better? libguile/module.c doesn't help me much
<jpoiret>eval.{c,scm} is too arcane for me
<ArneBab>mala: wisp should work pretty well with common lisp. : can have a special meaning, but it is usually not used on its own. And where it has a special meaning, you can use it as \:
<ArneBab>mala: you can use wisp2lisp to convert wisp code without any dependency on Scheme, so it can work for common lisp.