IRC channel logs

2021-12-16.log

back to list of logs

***Server sets mode: +ntz
***karlosz_ is now known as karlosz
<taw10>ArneBab: (AoC day 8 part 2) - indeed, I found myself moments away from grabbing my copy of SICP and starting to implement the "amb" evaluator. In the end I just brute-forced the possible signal assignments, since there aren't so many. It made my final code pretty satisfying
***chrislck is now known as chris-l
***chris-l is now known as chrislck
<KE0VVT>ArneBab: .w was already taken by Knuth's WEB and CWEB. .wisp
*chrislck envy those who push through AOC
<lampilelo>so far i'm managing, this year's challenges are definitely easier than the ones in 2018, when i tried aoc the last time
<jlicht>this year's day 1 is usually straigh-forward enough to start banging out code. And then day 2 reframes the challenge in such a way that you see the approach you should have been taking for day 1 ;-)
<jlicht>Nothing like the endorphin rush from solving day 1, and then seeing that day 2 is only a 2-line-change away!
<dsmith-work>UGT Greetings, Guilers
<ArneBab>taw10: can you share a link to your code?
<ArneBab>sneek: later tell KEOVVT according to https://www.file-extensions.org/w-file-extension-unix-silvio-levi-s-cweb-document-file CWED is no longer supported. Last release 15 years ago. There are three non-obsolete entries, but on *nix the extension is the marker for searching, the executing program is in the hash-bang.
<sneek>Will do.
<ArneBab>sneek: botsnack
<sneek>:)
<taw10>ArneBab: sure, here: https://github.com/taw10/advent-of-code/blob/main/2021/day8/day8part2.scm
<dsmith-work>!uptime
<sneek>I've been running for 2 days
<sneek>This system has been up 21 weeks, 1 day, 4 hours, 41 minutes
<dsmith-work>sneek: botsnack
<sneek>:)
<dthompson>is there any way to turn a file port into a file pointer for use with the ffi? or is that, like, a bad idea?
<dthompson>I think it's probably "a bad idea" (tm)
<dsmith-work>For a fd (file descriptor), yes. For a FILE *, pretty sure no.
<dsmith-work>dthompson: https://www.gnu.org/software/guile/manual/html_node/Ports-and-File-Descriptors.html#index-fileno
<dthompson>dsmith-work: right, that's what I thought.
<dthompson>I will solve my problem another way.
<dthompson>working with the libpng API. not the worst C API I've dealt with, but certainly not fun!
<dsmith-work>One I really hated was the zlib api. I think that's closely related to png, isn't it (api wise)?
<dsmith-work>Passing around structs that are modified back and forth..
<dthompson>I don't recall... I wrapped zlib way back in the day.
<dthompson>which then became the rough basis for an actually maintained guile-zlib
<dsmith-work>I used zlib for some compression at a place I worked years ago. The thought of wrapping that for Guile (back then) just made me Run Away.
<dsmith-work>Ports are different now though.
***taylan2 is now known as taylan