IRC channel logs

2021-10-25.log

back to list of logs

<lloda>daviid: i use https://paste.debian.net/1216735/
<civodul>dthompson: hey! can't wait for the Guix package for https://davexunit.itch.io/bonnie-bee :-)
<civodul>thumbs up, it looks pretty fun
<dthompson>civodul: hey thanks! the git repo has a guix.scm file so it's pretty easy to play for guix users. not 'guix install bonnie-bee' easy, but close enough!
<civodul>yup, neat
<dthompson>^ for anyone else seeing this: I made a game in 10 days for the lisp game jam. using guile, of course!
<civodul>i'll give it a go tonight instead of pretending to be productive ;-)
<civodul>woow, quite an achievement
<civodul>you're not a random hacker tho :-)
<dthompson>the game only takes a few minutes to beat. it's not that hard for people used to this type of game, but those unfamiliar with the shoot-em-up genre may find it difficult. if you're not having fun, just press ESC and that's that. :)
<dthompson>I'm just happy to have released a pretty decent free culture game.
<dthompson>code is gpl3, assets are cc-by-sa.
<chrislck>nice package... I presume this package will be runnable until the end of time?
<dthompson>hahaha probably not!
<dthompson>but the guix.scm makes it less prone to bitrot
<dthompson>guix.scm file*
<chrislck>here's my error report: https://pastebin.com/raw/bvCeUEUC
<civodul>dthompson: you can also add a channels.scm file to be on the safe side
<chrislck>(also tried guix environment --pure -l guix.scm)
<dthompson>looks like guile-sdl2 is failing. that is strange.
<dthompson>would need to turn up guix verbosity to understand why
<dthompson>always something wrong, despite my best efforts!
<dthompson>thanks for trying. I will help debug for as long you have the energy to keep trying.
<chrislck>np. may not be always timerich but can feed back regularly until it's fixed.
<dthompson>chrislck: I'm sure you have better things to spend time on. but if you do try again... happy to help. :)
<dsmith-work>Hey Hi Howdy, Guilers
<chrislck>np not sure how much I can offer; but if you push into your repo I'll feed back from time to time
<RhodiumToad>ugh, why do library authors invent so many ways to make memory management hard
<taw10>Guilty. Sorry.
<cwebber>hm
<lilyp>dthompson, chrislck: with recent guix, you should be able to simply (define chickadee (@ (gnu packages game-development) chickadee)) and ignore the local definitions
<manumanumanu>Ahoy hoy!
<manumanumanu>I haven't touched a proper computer for almost three weeks
<manumanumanu>I have almost forgotten how to touch type
<manumanumanu>and I had to think twice before a cdar.
<manumanumanu>anything fun going down?
<RhodiumToad>I found what I think is a bug in the module system :-)
<manumanumanu>exciting!
<manumanumanu>Code?
<RhodiumToad>the demonstration is here: https://gist.github.com/RhodiumToad/d92417aa4df36771ce993196c940a08f
<RhodiumToad>haven't written it up for a proper bug report yet
<RhodiumToad>the cause is that define-module* processes #:re-export _before_ processing #:duplicates, which seems both wrong an (as shown) inconsistent
<manumanumanu>ooh
<manumanumanu>that is a very nice find
<RhodiumToad>the fact that it behaves differently according to whether the sources were recompiled is a nice touch
<manumanumanu>which I don't really understand the mechanics of...
<RhodiumToad>even I haven't figured out exactly why that happens
<RhodiumToad>I'm guessing it's an expand vs. load thing (in the sense of (eval-when))
<lilyp>welp, I cheated really hard to get a backtrace :(
<civodul>dthompson: https://git.dthompson.us/guile-sdl2.git returns the wrong content-type it seems, which breaks guix.scm
<dthompson>lilyp: I need to build against git checkouts since I fixed bugs in the dependencies during the jam.
<dthompson>civodul: huh... I don't get that error here. I ran 'guix pull' this morning and rebuilt my environment, too.
<lilyp>Uhm, you really don't need to build against a checkout of the release tho
<lilyp>change a bit in the hash, it'll barf
<dthompson>I don't follow
<lilyp>Guix doesn't barf if you have the thing already in store.
<lilyp>You need to change the hash to make it see "oh, there's something different".
<dthompson>I've been pushing new commits all week and updating the definitions
<dthompson>not one problem
<dthompson>this would have to be a very recent regression that guix introduced
<civodul>dthompson: perhaps because you have it in cache?
<civodul>yeah what lilyp wrote
<lilyp>It's been there for ages :P
<dthompson>it's possible, but I ran 'guix pull' not that long before I started the jam.
<lilyp>Try `guix gc' otherwise if you're not convinced
<dthompson>and have had no problems.
<dthompson>I've developed this for literally years
<dthompson>this way*
<dthompson>I'll try a gc and see if I can reproduce
<lilyp>Trust me, I've been bitten by this for the past two years.
<dthompson>by other git repos? or just mine?
<civodul>yeah, you can try "guix build /gnu/store/1sfyih800f5w0qzrx0hj6gvhmk5vi712-git-checkout.drv --check"
<lilyp>by my own contribution to Guix channels, including the main one
<dthompson>I will run 'guix gc' and see what happens
<dthompson>the fact that this appears to be a non-universal issue is interesting
<dthompson>I just rebuilt the environment from scratch and it all worked.
<dthompson>why can't I reproduce this issue???
<cwebber>o/
<civodul>dthompson: did you try the command above?
<civodul>probably you can't reproduce it because you already have the output of that derivation in store
<dthompson>civodul: I gc'd.
<dthompson>it cloned again. no issue.
<civodul>(cd /tmp/guile-sdl2; git checkout d31c27ac48f81a534b28531e3d5fa626890be59f; guix hash -rx .) => 106pnw4ifgkrgyj84jgpz5gnbgshjcrp10wcyw1skgzqni1mrmg3
<civodul>it's a good idea to add the usual 'file-name' field because that avoids mistakes like when you update the commit ID but forget to update the content hash
<civodul>anyway, not sure if that's what happened, weird!
<civodul>dthompson: i just played, got to hit "x" a few times and all, much fun :-)
<civodul>and music!
<dthompson>civodul: thanks! first time I've made game music. very basic but works.
<dthompson>I'll check for mistakes with the git checkouts but I just saw guix re-clone the repos. when I update the commit id I always edit the hash so that guix throws an error about it. then I copy/paste the actual hash it outputs.