IRC channel logs

2021-10-03.log

back to list of logs

<daviid>vijaymarupudi: I pushed a patch that cleans two unecessary weak hash remove entry calls - but this won't affect the overall picture of the statprof of your paste, because as the app does nearly nothing but, once it started, allocate and immediately auto freeing iters, it is expected that a high to very high proportion of such a 'wait till you click a button' app that does allocate/auto free spend nearly 'all its time' doing ... just
<daviid>that :)
<daviid>vijaymarupudi: note that you shold pass -1 to the buffer insert command, like (insert buffer start-iter message -1), because the last arg is the length in bytes, not chars ...
<daviid>i shall override that method to not require its last arg actually, will do and ping g-golf users here (as i should also override gtk-list-store-new to not require its first arg... dito)
***Noisytoot is now known as GPLv3
***GPLv3 is now known as Noisytoot
<vijaymarupudi>daviid: good catch, forgot about that distinction!
<vijaymarupudi>daviid: Appreciate you trying to optimize that, it wasn't an issue for me, just thought you'd be interested :)
<daviid>vijaymarupudi: np! it's nice to have you try and 'stress' g-golf
<vijaymarupudi>daviid: :)
<vijaymarupudi>daviid: I think I've been testing GLib lately
<vijaymarupudi>with the exception of a few functions being missing, it's been pretty solid
<vijaymarupudi>daviid: Gio is probably going to be next, since a good DBus interface would be really nice in Guile for personal reasons
<daviid>vijaymarupudi: testing DBus using g-golf would be excellent, and probably reveal some other bugs ... - i think there is a guile-dbus 'manual' binding attempt 'out there', not sure how far it went, but when the subject (did) 'raise(s)' among us here or in #guix, i (did) suggest the 'g-golf route', that nobody followed yet :) - imo, manually binding DBus is a big can of worms :)
<vijaymarupudi>Haha, great, well let's see how it goes :)
<daviid>vijaymarupudi: here are two refs wrt guile and libdbus, not the Gio DBus API's (nor the low-level nor the high-level API, but 'direct' libdbus bindings - it is not manual, it uses NYACC ... just in case it would be helpfull, here - https://lists.gnu.org/archive/html/guile-user/2018-12/msg00150.html and https://lists.gnu.org/archive/html/guile-user/2018-04/msg00031.html
<vijaymarupudi>daviid: Thanks! Hopefully I won't have to :)
<apteryx>how can we check if a command is available on PATH with guile?
<apteryx>somethnig better than checking for non-zero exit status of (system "command -v some-command") ?
<apteryx>so far, I'd go with something like: (zero? (status:exit-val (system "command -v something")))
<vijaymarupudi>Split path by :, iterate each directory, and each if (access? (string-append dir "/" executable) X_OK) is true?
<vijaymarupudi>check*
<vijaymarupudi>Something like this: https://paste.gnome.org/pvg8tdoqb
***sneek_ is now known as sneek
***berndj-blackout is now known as berndj
<apteryx>eh. I wish there were more batteries in the standard Guile libraries.
<apteryx>in Python, for example, that'd be: import shutil; shutil.which('my-command')
<apteryx>(returns its path or nothing if it's not found)
***duncanm_ is now known as duncanm
<daviid>apteryx: you could do (system "which cmd") and grab the result ...
<daviid>if you need the path if the cmd exists, you'd need to use (ice-9 popen) ...
<apteryx>shutil.py does something along the lines of what vijaymarupudi suggested (scan the PATH contents for an accessible file)
<apteryx>daviid: ah, in Guix this is about what 'which ' in (guix build utils) does, IIUC
<apteryx>at some point we should look at what's been accumulated in Guix that'd better be in Guile itself and move things to the core library :-)
<vijaymarupudi>daviid: I've been trying guix recently, is there a way for me to install the g-golf devel branch using it?
<ArneBab>sneek: later tell vijaymarupudi: I recently wrote how to install custom libraries in practice. It should take you the way to package your own version of g-golf: https://www.draketo.de/software/install-on-guix
<sneek>Will do.
<ArneBab>sneek: botsnack
<sneek>:)
***notzmv- is now known as notzmv
<excalamus>hello, guile
<lampilelo>hello, excalamus
<rlb>Does anyone know offhand whether changing the configure --with(out)-threads setting still changes the library ABI in a backward incompatible way?
<rlb>(cf. https://bugs.debian.org/995614)
<fnstudio>i see there's a +inf.0 value built in but (/ 1 0) then raises an error instead of giving inf
<fnstudio>i guess there's a very valid reason for that of course
<fnstudio>just wondering
<RhodiumToad>try (/ 1 0.0)
<stis>Sunday greeting everyone!