IRC channel logs

2021-09-18.log

back to list of logs

<flatwhatson>muradm: it's not uncommon to have a max-requests-per-connection on server side, or a max lifetime of a connection
<flatwhatson>you could test that theory by trying a different host, which might have different rules
<flatwhatson>but in general if re-using a socket for multiple requests, you'll need to handle the reconnection case
<daviid>i have a doubt: can i rely on the 'fact/assumption' that if i hold a reference to a pointer to a bytevector, although i do not hold a reference to the bytevector itself, it remains gc protected until the pointer (to it) becomes unreachable?
<muradm>morning guile
<muradm>flatwhatson: yes I tought about server request throttling, but putting sleep's in between like 2 seconds before each pocking, i still get same result
<muradm>wierd
<flatwhatson>sure, but it could be related to number of requests, in which case a sleep wouldn't matter
<muradm>i think it is something different, looks like something getting filled
<muradm> https://paste.rs/Bls
<muradm>first i get index, then i map over it
<muradm>map reaches 2016-05 and reconnects start
<muradm>on 2016-12 guile silently crashes
<muradm>with 141
<muradm>flatwhatson: i don't have any problem doing same thing with wget mirror
<muradm>to the exact same url
<muradm>wget just works.. :)
<flatwhatson>sure, wget will automatically reconnect on Connection: close header
<flatwhatson>it certainly doesn't do the whole thing via a single socket...
<muradm>somewhere i remember i saw exit codes of guile
<muradm>ok i see now what is the problem
<muradm>still would be happy to find list guile command exit codes
***iskarian is now known as Guest522
<stis>Tjnixen guilers!
<stis>Hej guilers!