IRC channel logs

2021-08-29.log

back to list of logs

<dokma>will do
<dokma>leoprikler: (call-with-new-thread stop-server-and-clients!) works perfectly with guile 2.2
<dokma>leoprikler: all threads are cleaned completely and control returns to the C++ app in which guile repl is embedded.
<dokma>call-with-new-thread was what I needed all the time.
<Zelphir>Hello!
<stis>Tjena guilers!
<Zelphir>Is it Swedish? Hi stis!
<tohoyn>Terve
<Zelphir>Language auto-detection is switching between Swedish, Finnish and Serbian ^^ My Swedish is very limited: "Hey", "Heydo" and I think "tak" or "tag" or so for "thanks"?
<stis>Zelphir: yep swedish, a bit order urban greeting
<Zelphir>:)
<stis>s/order/older/
<stis>thanks is tack, but tak is close.
<stis>tjena is common in old swedish black and white movies
<Zelphir>I see!
<tohoyn>daviid: is it OK to you if I build the G-Golf debian packages to use Guile 3.0?
<daviid>tohoyn: sure, do as you wish/may follwing debian's rules ...
<tohoyn>daviid: ok. I'll rebuild the package soon and I'll take the newest upstream version.
***dekenevs is now known as kitzman
<manumanumanu>God kväll, stis .
<manumanumanu>what is going down?
<stis>manumanumanu: Working with a fibers tool (stis-engine)
<manumanumanu>do you have a use-case in mind, or is it just for fun?
<stis>for eaxample very fast streaming big datastructures to the network compilin.
<stis>for example split an image RGB stream into an R an G and a B stream, transfomr them and then combine them again outputting it
<stis>All working in the fibers world with fast task switching and utilizing of multiple threads
<stis>see email list for a client and server example
<stis>I have been a bit unhappy with the parogram interface, but I think it starts to get good now
<stis>you can easilly write transformers in C and glue them together in guile to for example make use of vectorized operations in the CPU
<stis>usually streaming can be avoided, but as data grow to the GB level and you do not want to stall the machine this tool come in handy
<stis>I also made a very fast serializer and deserialiser recently that also work with streams
<stis>I have a slow one as well in pure scheme
<stis>A use case for that would be to transfer json and html by binary transporft in stead of sending it in clear text, you can easilly push the stream through a gzip stream compresser and decompresser. No big datastructures created
<stis> https://gitlab.com/tampe/stis-engine/-/tree/master
<stis>the code starts to become beutiful in my opinion now
<stis>need to debug it after the latest refactoring¨
<stis>manumanumanu: ^^
<stis>manumanumanu: and you whats up, was it scribolo?
<manumanumanu>skarbl, or something like that :)
<stis>coolio
<manumanumanu>That is put on ice. I am fixing the reference implementation of srfi-171 with the stuff I cleaned up for inclusion in guile.
<stis>aah nice!!
<stis>Oh and I am trying to make an app also. I have a little idea, prototyping it in guile.
<manumanumanu>There were some things that I realized I must have borked somehow: In my own code I had bytevector-u8-transduce always, but in the code I sent arthur the guile module says bytevector-u8transduce. Quite embarrasing (spelling of that?) :(
<stis>Maybe mayby I can get sine coins from that so that I can buy a Tesla!! And maybe even be able to fund some work on guile and other pet projects of mine!
<stis>manumanumanu: Did you see the tesala AI day? Absolutely stunning, I'm blown away by their innovation
<stis>So as a techie I just must get a Tesla. But you know, I probably end up with an electric bike ...
<manumanumanu>I don't drive :)
<manumanumanu>Or rather, I moved into town, and now I am in an electric car sharing pool.
<manumanumanu>which I never use
<manumanumanu>but a colleague of mine bought a tesla, and it is a gadget I don't have, which means I have tech-envy.
<stis>great. The commute to my home town where my friends are is 4hour with bus and train, at best 3hour. With car less then 2 hours
<stis>lol
<stis>The Tesla plaid is insane, pure rocket science, an a piece of art tecnology wise. But wy way over my budget
<stis>But the flip side of taking the train and bus is that I can work while on the journey. The quality of the busses and trains are really good.
<stis>My son hate it though because of the long time
<dsmith>Ya I've been drooling for a tesla. Ended up with a Kia Rio.
<stis>By the way stis-engine is a spin off, of that app work. I am using g-golf to prototype the ui
<stis>I will now write some test cases and then ready to documetn it
<stis>My take away from this work is probably that fibers are amazing
<stis>and once again I find that scheme is such an incredible language