IRC channel logs

2021-08-23.log

back to list of logs

<apteryx>weird, I got read-line reading (buffering in) *two* lines, then outputing just the first. The next time it is called, the second line is ignored and it blocks for more (well, suspends in my case, as I'm using suspendable ports).
<apteryx>here's a small strace excerpt showing select returning, a read with two lines in, a write showing what it got from read-line, and the next read (from read-line) returning EAGAIN instead of returning the 2nd line it should have kept in the port buffer
<daviid>sneek: later tell vijaymarupudi I fixed g-golf so, finally, guilemay GC <gobject> instances when applicable - please pull/make/install/try (devel branch)
<sneek>Got it.
<daviid>str1ngs: ^^
<daviid>g-golf users donot need to 'manually' call unref anymore ...
<daviid>here is an example (based on vijaymarupudi snipset pasted here afew days ago) - https://paste.gnome.org/pn6cefhdi - note that the msgs in the repl won't appear in 'real' g-golf, those trace msgs were added to test ... if you wish to also trace gc'ing <gobject>instances, visit (g-golf hl-api gtype) and uncomment line 138 and uncomment s-expr starting line 143 ...
<daviid>going afk, bbl
***Server sets mode: +ntz
<apteryx_>sneek later tell maximed I posted this to guile-user, as a follow-up to the problems I've been having with suspendable ports, in case you'd have an idea: https://lists.gnu.org/archive/html/guile-user/2021-08/msg00028.html
<sneek>Got it.
***apteryx_ is now known as apteryx
<dsmith-work>Morning Greetings, Guilers
<stis>hello guilers!
<stis>hi dsmith-work!
<dsmith-work>stis: Hey hey. Hows the python stuff going?
<stis>working on faster serializing/deserializing
<stis>good for pure guile programs as well
<stis>latest contribution is to serialize lambdas, got hashtables and structs/classes working yesterda
<stis>and you how goes?
<stis>dsmith-work: ^ ^
<stis>Oh and I looked into what Tesla AI day delivered. I'm really blown away, holy shit.
<dsmith-work>stis: Not much guile related. Doing Xilinx stuff at work.
<stis>k
<stis>yey lambdas are now serialized, works like a charm
<str1ngs>daviid: thanks daviid will test this when I have some time.
<str1ngs>hello, I have been working on a toy bitcoin scrypt algorithm. here is what I have so far https://paste.debian.net/1208732. Is there a better way to swap hex byte order? currently I'm using the swap-order procedure to change endiness to big from litte.
<str1ngs>err I meant I'm swapping from litle to big
<apteryx>has anyone here experience with suspended ports? Or an example to point me to? I've attempted using the suspendable read-line but it causes problems: it buffers more than a single line at a time yet returns just the first one. The next call to it causes it to suspend instead of returning the extra buffered data, leading to data loss.
<apteryx>I've shared a minimal reproducer of what I'm doing that exhibits the above problem: https://lists.gnu.org/archive/html/guile-user/2021-08/msg00028.html
<dsmith>dsmith-work: Hey
<leoprikler>apteryx: just a question, is it fine to not wrap your continuations in call-with-prompt?
<apteryx>leoprikler: I think that would also lead to data lost, no?
<leoprikler>idk haven't tried
<leoprikler>oh, wait, you do call it with a prompt
<leoprikler>nvm all is well in that regard
<leoprikler>apteryx: perhaps you're running into an infinite loop where you call (cont) more than once though?