IRC channel logs

2021-07-07.log

back to list of logs

<dsmith>!uptime
<sneek>I've been running for 38 seconds
<sneek>This system has been up 5 days, 9 hours, 39 minutes
***bandali_ is now known as bandali
<rlb>(Oh, I also needed "-shared" on not macos, and "-bundle -undefined dynamic_lookup" on macos, apparently.)
***zap1 is now known as zap
<sarna>leoprikler: I can just as well run `ls` from shell instead of `find-files` from guile, right?
<sarna>it's not like the files will disappear in the meantime..
***karlosz_ is now known as karlosz
<sarna>leoprikler: I noticed that hall is capable of creating guix files, so I just nuked `guix.scm` and let hall generate it - now it works!
<leoprikler>sarna: ls won't give you the full tree, but yes
<leoprikler>also IIRC hall expects you to regenerate everything if stuff changed, so yeah, that's probably expected
<sarna>oh, so I don't need to modify these files at all? that's neat, TIL!
<sarna>thanks :))
<leoprikler>sarna: au contraire, since they're machine-generated, changes you add to them will be lost!
<sarna>leoprikler: that actually happened! and I typed them out again 🙈
<sarna>I'm not the sharpest tool in the shed
<leoprikler>you could (package (inherit (load "guix.scm")) ...) if you're really cheeky :P
<leoprikler>is there a way of composing procedures with setter?
<leoprikler>e.g. (set! ((compose bar foo) spam) value) -> (set-bar! (foo spam) value)
<sarna>is there a complement function in guile? I mean something that'd roughly do `(lambda (func) (not (func)))`
<flatwhatson>sarna: yes, negate
<sarna>flatwhatson: thanks!
<sarna>are there any utility functions for paths? right now I'm appending strings, and that doesn't feel very solid :( I haven't been able to find anything in the guide
<flatwhatson>not that I know of! you have string-append, string-join, and file-name-separator-string if you're concerned about portability
<flatwhatson>from what i've seen in guix, using string manipulation for paths is perfectly normal
<sarna>I see. thanks again :)
<leoprikler>for the record, there are several libaries doing path strings (one written by yours truly), but it kinda seems Guile folks prefer doing string manip
***chris is now known as Guest7431
<leoprikler>hum, can we do mv-respecting setters?
<lampilelo>it would be nice to have maybe an ice-9 module for paths, also realpath would be cool
<dsmith-work>Hey Hi Howdy, Guilers
<leoprikler>isn't realpath canonicalize-path?
<RhodiumToad>not all realpath implementations return an absolute path in all cases, apparently
<RhodiumToad>though the spec for realpath() does seem to require it
<RhodiumToad>otherwise, yes, canonicalize-path is documented as doing what realpath does
<lampilelo>ah, right, i always forget about canonicalize-path, always searching for realpath in the docs and not finding it
<apteryx>is it possible to run Guile on Android?
<apteryx>perhaps as a Guix pack?
<drakonis>hmm, use something like userland or termux
<drakonis>it is theoretically possible
<apteryx>'pkg search guile' in termux returns no result
<drakonis>termux is based on a subset of debian's packages
<drakonis>you'd need to use something like userland instead
<drakonis>which provides a whole distro
<lampilelo>apteryx: maybe it's possible with this: https://developer.android.com/ndk/guides
<lampilelo>if you manage to do it, please tell me, i've been thinking about trying it myself but never got to it
<dsmith-work>sneek: botsnack
<sneek>:)
*apteryx installs UserLAnd from F-Droid
<apteryx>seems arch and debian/ubuntu would have only guile 2.2, at least in their default repo
*apteryx tries 'guix pack --target=aarch64-linux guile -S /bin/guile=bin/guile'
<morganw>I think it is now split in packaging between guile-3.0 and guile-2.2, at least in Debian 11.
<leoprikler>debian has the super new 3.0.5 in unstable IIRC :)
<daviid>it is in testing even...
<civodul>apteryx: *aarch64-linux-gnu :-)
<daviid>apteryx: fwiw https://packages.debian.org/search?keywords=guile-3.0&searchon=names&suite=all&section=all
<morganw>Would anyone happen to know what the status is for building with msys2?
<daviid>morganw: https://packages.msys2.org/search?t=binpkg&q=guile
<morganw>Oh, I meant the current version, but thanks for the link I didn't realise it was available as a package.
<morganw>From the mailing list (~2020) it seemed that building version 3 wasn't easily doable on Windows.
<daviid>morganw: windows is 'another story', msys2 current version is 2.2.7-1
<apteryx>OK, so for a "multi-platform" application, Guile is currently at 2.2 (thanks to windows)
<apteryx>but could get by with WSL perhaps? which is the Ubuntu's runtime, IIUC.
<apteryx>has someone managed to run Guile on WSL (the Linux-ABI compatibility layer for Windows thing)?
<morganw>I'm interested in distributing a working program (or extending an existing one with scripting) so I can't really assume the WSL bits are setup. It also causes conflicts with default configurations for Docker and Hyper-V.
<drakonis>wsl2 is the better option but it is just linux in a vm
<daviid>fwiw, imo if you don't need a 'native' version on win, msys2 might be a much better choice, for various reasons, one is that you can prepare everything, then send a 'complete' msys2 image, and that's it
<leoprikler>so packaging my software for msys will be as easy as it is to package it for arch? :)
<daviid>leoprikler: i didn't pkg anything myself, i prepare(d) an msys2 image with guile, guile-cv (using the autotools, so dead easy), other guile scripts, then cp the image on a usb key and sent it to the 'customer' ... that'sit
<leoprikler>hmm, so lemme see if I understand this correctly
<leoprikler>you start with some msys2 build, then compile+install guile, compile+install guile-cv and finally tar+gz everything into one big shiny ball
<leoprikler>with "compile+install" being your typical "autoreconf -vif"..."make install" chain, right?