IRC channel logs

2021-06-19.log

back to list of logs

<emestee>any way to do destructuring bind on a list without resorting to syntax?
<RhodiumToad>match?
<emestee>yep thought so ;P
<RhodiumToad>there's also some stuff in one of the srfi modules for converting lists into multiple values
<lampilelo>also let-optional and let-keywords, or you could return values if possible and use let-values, call-with-values or receive
<RhodiumToad>I was thinking of srfi-71, which allows things like (let ((first next rest (uncons-2 somelist))) ...)
<leoprikler>match is syntax tho
<RhodiumToad>what binding construct is not syntax?
<leoprikler>eval >:)
<emestee>RhodiumToad: oh this could be useful, thanks
<RhodiumToad>I'm still kind of on the fence about which of the various binding constructs to use for multiple values.
<RhodiumToad>one can of course import just uncons etc. from srfi-71 without importing its redefinition of (let ...)
<flatwhatson>it's not the most ergonomic, but srfi-11 is in r6rs and r7rs
<RhodiumToad>I know about all the options
<RhodiumToad>let-values is very heavy on the parens
<flatwhatson>yep, just making the case for the "don't overthink it" option :P
*taylan really doesn't mind the number of parens on srfi-11
***sneek_ is now known as sneek
<rlb>manumanumanu: there's some discussion in the info page https://www.gnu.org/software/guile/manual/html_node/Strings.html -- and yeah, I think substring always shares (substring/copy doesn't).
<dsmith>sneek: botsnack
<sneek>:)