IRC channel logs

2021-06-08.log

back to list of logs

<lispmacs[work]>i seem to recall there was some trick I could do to hook a cleanup action to an objects garbage collection event. Am I remembering correctly?
<taylan>lispmacs[work]: I think they're called GC hooks?
<mfiano>You mean finalizers?
<lispmacs[work]>those both sound vaguely familiar
<lispmacs[work]>I think Guardians was what I used in the past
<lispmacs[work]>a "finalizer" sounds simpler, but I don't know how to make or attach one
<mfiano>They're not a trick. Infact, it is usually the developer being tricked, because they aren't reliable; they have a few caveats.
<dsmith>!uptime
<sneek>up 5 weeks, 12 minutes
<mfiano>Section 5.5.4 explains why they should probably be avoided.
<ixmpp>(lambda (f g h x) (if (f x) (g x) h)) does this function or similar exist anywhere?
<ixmpp>Dunno if im reinventing the wheel
<dsmith>sneek: botsnack
<sneek>:)
<dsmith>sneek: seen dsmith-work
<sneek>dsmith-work was last seen in #guile 13 hours ago, saying: {appropriate time} Greetings, Guilers.
<dsmith>sneek: botsnack
<sneek>:)
<tohoyn>topoi: here is a function computing permutations: https://paste.debian.net/1200366/
<lampilelo>tohoyn: it's 10x faster if you use append!
<dsmith>sneek: botsnack
<sneek>:)
<tohoyn>here is a permanent link: https://paste.debian.net/1200368/
<tohoyn>sneek: botsnack
<sneek>:)
<lampilelo>actually using cons instead of append is A LOT faster
<tohoyn>lampilelo: here is an updated version: https://paste.debian.net/1200371/
<lampilelo>yeah, this doesn't do any garbage collection
<leoprikler>tohoyn: this looks nice and all, but it computes recursive perms many times
<leoprikler>I think one can do faster if one counts from 0 to k instead of the other way round
<tohoyn>ok
<tohoyn>this page claims that R7RS and R6RS library syntaxes are similar: https://www.gnu.org/software/guile/manual/html_node/R7RS-Support.html
<tohoyn>is it so? AFAIK R6RS defines a "library" form and R7RS a "define-library" form.
<wingo>similar != the same
<tohoyn>wingo: yes, but are the syntaxes compatible as the WWW page says?
<wingo>you should check :)
<tohoyn>wingo: IMHO the syntaxes are not fully compatible, though they are similar
<dsmith>!since
<dsmith>!since
<dsmith>!since
<sneek>23 seconds
<dsmith>!uptime
<sneek>up 5 weeks, 8 hours, 59 minutes
<dsmith>!uptime
<sneek>This system has been up 5 weeks, 9 hours
<dsmith>!since
<sneek>I've been running for 23 seconds
<dsmith>goodbot
<civodul>sneek: botsnack
<sneek>:)
<lloda>when i've had to do combinations/permutations, i've just transcribed knuth to C
<lloda>a library of 'best known' routines for Guile would be very nice to have
<sneek>/who *
<sneek>/who *
<dsmith>!since
<sneek>I've been running for 34 minutes and 41 seconds
<chrislck>lloda: isn't it a matter of copying rosettacode.org into (ice-9 algorithms) ?
<lloda>that sounds too simple to work, but maybe it's a starting point chrislck
<alextee>making an appimage and I noticed that this directory is 30mb: usr/lib/x86_64-linux-gnu/guile/2.2/ccache
<alextee>that's precompiled guile stuff right? is it safe to delete?
<dsmith-work>Morning Greetings, Guilers
<dsmith-work>Did someone bisect the evaluation problem with Geiser?
<dsmith-work>Yes! http://logs.guix.gnu.org/guile/2021-05-06.log#005719
<wingo>iirc lampilelo fixed it in geiser too
<dsmith-work>Hmm. Works with a fresh emacs process. Proabably some old geiser code
<dsmith-work>Oh! It's such a delight to use!
<yoctocell>Is there an empty char?
<yoctocell>#\null ?
<emanuele6>you mean the null character? (ascii 0)
<emanuele6>that is #\nul
<emanuele6>but i think #\null is a valid alias
<emanuele6> https://www.gnu.org/software/guile/docs/docs-2.2/guile-ref/Characters.html
<yoctocell>emanuele6 yeah, ok, thanks!
***taylan2 is now known as taylan
<lispmacs[work]>is there a convenient debugging procedure in Guile for "print out the return value of this expression and then return that return value"?
<manumanumanu>pk
<manumanumanu>(pk 'hej) => ;;; (hej) and returns 'hej
<lispmacs[work]>manumanumanu: okay, thanks
<lispmacs[work]>after doing a (load file-path) to re-load a module from the interpreter, is there any reason to ",use" the module again?
***jackhill_ is now known as KM4MBG
***KM4MBG is now known as jackhill[m]
***jackhill[m] is now known as jackhill