IRC channel logs

2021-05-29.log

back to list of logs

<chrislck>anyone remembers OPEN "COM1:300,N,7,1"?
<chrislck>guile doesn't even have a (CLS)
<taylan>sneek: botsnack
<sneek>:)
<lampilelo>did mwette stay behind on freenode?
<taylan>lampilelo: he asked on the ML for assistance, ERC related issues I think
<lampilelo>i see
<lampilelo>i'll reply to him
<dsmith>I mentioned to him he needed to register his nick
<lampilelo>i have some more info because the current version of erc doesn't really know what libera is so there are some issues
<dsmith>I've been using erc, but have beem msg'ing nickserv by hand.
<dsmith>Prob should tune that up
<lampilelo>i'm writing the email, you should read it too in that case
<lampilelo>lol, i think i sent it just to him, not to the mailing list
<lampilelo>dsmith: i uploaded an excerpt from the mail: http://dpaste.com/EQAEJ9HSB
<lampilelo>for your nickserv issues
<dsmith>lampilelo: Thanks!
<dsmith>Yey
<lampilelo>emacs 28 will fix it, i believe
<dsmith>I'm using ERC with GNU Emacs 26.1 (x86_64-pc-linux-gnu, GTK+ Version 3.24.5, multi-tty) of 2021-01-30.
<mattrw>Hi All. This is Matt, formerly mwette.
<dsmith>Not even on 27 yet
<lampilelo>now to figuring out how to send mails to the mailing list with gnus using gwene nntp, is it possible even?
<dsmith>mattrw: wb!
<lampilelo>mattrw: did you get my email?
<mattrw>thx!
<lampilelo>you got here oddly quick
<philip>Is it possible in Guile to restrict the effect of read-hash-extend to a certain dynamic extent, say with dynamic-wind? In Racket, I would parameterize current-readtable.
<mattrw>I found https://libera.chat/guides/registration
<lampilelo>dsmith: you're using debian? i think ubuntu already has 27
<dsmith>Yep Debian.
<mattrw>I'm on Ubuntu 21.04 and it has emacs 27.1
<lampilelo>mattrw: ah, ok, i sent you an email with some workarounds for erc and libera, but for some reason it was off mailing list
<mattrw>lampilelo: I got your email. Thanks. I'm just using libera now, and things are working so hoping it stays that way. Thanks for the help.
<lampilelo>mattrw: actually i was asking about you earlier because i tried to play with nyacc and had some issues with it
<mattrw>You're not alone. :)
***KindOne_ is now known as KindOne
<dsmith>philip: Pretty certain read-hash-extend is a global setting. However Guile now has in recent changes a Scheme based reader insted of a C reader. So who knows, maybe that change.
<lampilelo>mattrw: for a function taking a struct, not a pointer, it made a function that takes a nyacc version of that struct and destructuring it internally to a bytevector but then throwing an error because the internal function wanted to have the bytevector by pointer, not by value
<dsmith>that can change
<lampilelo>is this a known issue?
<lampilelo>(i'm talking about the ffi functionality)
<mattrw>So, I'm not sure exactly. If the C function takes a struct (by value) then the fh-link-proc should be using a (list xxx) for the struct arg, not a '*. That may be broken in pre-1.04.0 but I hope working.
<mfiano>Hello all
<lampilelo>mattrw: the generated code's internal function has this as the argument list (list (list ffi:uint8 ffi:uint8 ffi:uint8 ffi:uint8)), but when ((fht-unwrap Color) color) is passed to it breaks, but it works if you wrap it with pointer-to
<lampilelo>hi mfiano
<mattrw>Ah. OK. The signature is OK but looks like the unwrapper is not working.
<mfiano>Never used a Scheme before, but somehow spent the day reading the Guile reference guide.
<mattrw>mfiano: maybe this: https://www.scheme.com/tspl4/start.html#./start:h0
<lampilelo>mattrw: unwrapper returns a plain bytevector with all of the data from the struct
<mattrw>Hmm. So I wonder if I need to use Guile's make-c-struct. That would be sad.
<mfiano>I will probably get more from the manual. There seems to be a lot of overlap with Common Lisp in those getting started guides.
<mfiano>I should have mentioned I've been using CL exclusively for the last 20 years or so
<mattrw>lampilelo: and I just found another bug in the passing struct stuff.
<mattrw>lampilelo: added as bug #60697
<lampilelo>and also i discovered the existance of c99-std-help the really hard way - the library included <math.h> - imagine trying nyacc for the first time and getting some weird syntax errors
<lampilelo>mattrw: thanks
<lampilelo>nyacc is neat
<mattrw>lampilelo: maybe only bytevector->pointer is needed. Can you try that?
<mattrw>(Meaning just hack the .scm output file just to see if it works.)
<lampilelo>i can check it, but give me a moment
***Noisytoot is now known as [[
***[[ is now known as Noisytoot
<lampilelo>mattrw: bytevector->pointer works, just like pointer-to
<lampilelo>are they different?
<mattrw>yes. Full fix maybe this easy:
<mattrw>--- a/module/system/ffi-help-rt.scm
<mattrw>+++ b/module/system/ffi-help-rt.scm
<mattrw>@@ -321,7 +321,8 @@
<mattrw> (define type
<mattrw> (make-fht (quote type)
<mattrw> (lambda (obj)
<mattrw>- (bytestructure-bytevector (struct-ref obj 0)))
<mattrw>+ (bytevector->pointer
<mattrw>+ (bytestructure-bytevector (struct-ref obj 0))))
<mattrw> (lambda (val)
<mattrw> (make-struct/no-tail type (bytestructure desc val)))
<mattrw> #f #f
<mattrw>
<Noisytoot>mattrw: use a pastebin (like bpa.st or paste.debian.net)
<mattrw>Noisytoot: thanks -- usually do, senior moment
<mattrw>lampilelo: pasty: https://paste.debian.net/1199323/
<lampilelo>mattrw: you should ask on #libera about recovering your nick, it will probably expire since you didn't confirm the registration
<lampilelo>i'll try that patch
<mattrw>lampilelo: thanks.
*mattrw afk for a bit
***xkapastel is now known as abcdefrs
***abcdefrs is now known as xkapastel
<lampilelo>mattrw: it works now but you forgot to add ffi: prefix to bytevector->pointer