IRC channel logs

2021-02-02.log

back to list of logs

<daviid>it occurs to me that 3.0.5 depends or indirectly depends on gperf, which is not checked by configure and make fails (here, gperf was not installed) - should we not add a configure.ac check for it?
***apteryx is now known as Guest58390
***apteryx_ is now known as apteryx
<RhodiumToad>depends on gperf?
<RhodiumToad>I build the freebsd port in a clean jail with only the declared dependencies, which don't include gperf
<tohoyn>I remember encountering a gperf dependency, too.
<wingo>gperf only needed when building from git
<rlb>Hmm, hit a problem in lokke -- clj allows interleaving defs and expressions like 3.0, but I forgot 2.2 didn't. Unless I can think of a reasonable way to adapt for 2.2, I suppose I might just mark interleaving as a known issue if you're using 2.2...
<ArneBab>sounds good.
<ArneBab>→ go for 3.x?
<rlb>Yeah, currently support/test both, but lean against diverting too much effort to accommodate 2.2 if/when something requires more work there, as compared to other improvements. Realized it last night, and think I'll probably just mark it as a known issue for now.
<apteryx>is there no ,continue in the Guile debugger?
<apteryx>I guess ,finish should do the same
***metro is now known as metreo
<manumanumanu>rlb: I have a macro that shadows the basic built in forms
<manumanumanu>so that you can have definitions in expression context
<manumanumanu>rlb: https://hg.sr.ht/~bjoli/guile-define
<daviid>davexunit: http://haunt.dthompson.us is down?
<daviid>that's the link that is on http://sph.mn/foreign/guile-software.html, let me know if it needs to be changed ...
<manumanumanu>rlb: Note however, that guile 2 does _NOT_ optimize letrec very well. Using those macros, define in expression context is slower than using let and let*
<manumanumanu>and forms that do not import that module still don't allow defines in expression context. Say you import srfi-9, 11 or (ice-9 match), those bodies wont be transversed for inline defines.
<davexunit>daviid: correct link is https://dthompson.us/projects/haunt.html
<manumanumanu>rlb: it was in guile-3 when guile started optimizing letrec to be as fast as let and let*. Using define instead of (let ...) in guile prior to 3.0 means a measurable overhead. You'd think it wouldn't be that much, but I had code that got a 10% speedup be rewriting 4 defines as let*.
<daviid>davexunit: ok tx
***ngz` is now known as ngz
<davexunit>np
<rlb>manumanumanu: ahh, interesting -- thanks. That might explain some of the notable performance improvements I've seen with 3.0, since at the moment the clojure fn expansion involves letrec.
<wingo>fun bug: (read-disable 'square-brackets), then (call-with-input-string "]" read)
<wingo>gives EOF
<rlb>oops...
<rlb>wingo: any idea if it's intentional that when you hit an error in the repl, the prompt and printer (at least) switch back to the default (assuming you'd specified some other one for a dialect)?
<wingo>not intentional
<wingo>i suspect there are many ways multi-language support can be improved
<rlb>i.e. in lokke, after an error, you're in a new prompt, still (current-language) -> lokke, but the printer is the scheme printer, and the prompt is back to the default guile prompt.
<wingo>sounds like a bug :)
<rlb>exiting the recursive repl of course returns to the lokke printer and prompt.
<rlb>ok, thanks - I might look in to it later if I have time.
*rlb has encountered a handful of things like that, but still, overall it's worked plausibly well.
<cybersyn>hiya guilers! i'm really more of a racketeer, but i'm on guixos, a big fan of what i've come to know of guile, and thought of something that would be more "guile" in general
<cybersyn>so, over the past decade i've made my living as a new media artist -- working on commission to create various installations for the events of big brands (not what i want to do, just the way i figured out how to make money while also pursuing philosophy)
<cybersyn>since the pandemic, i started picking up gigs in UX design,
<cybersyn>i was just thinking that, with all of this awful "learn to code" marketing thats happening, if there was a counter campaign, complete with nice designs that perform a sort of /Verfremdungseffekt/ on the concept of "learn to code", with some sort of message: software is labor, if you're going to work you might as well work on means of production that you own after the job is over
<cybersyn>anyway, sorry for the sudden intervention, i was just thnkng about things and that crossed my mind as a nice way to turn crowds that might be learning to program right now to Dasein-oriented-programming
<cybersyn>(go on with your days, please don't mind me)
***amiloradovsky1 is now known as amiloradovsky
<cybersyn> /wallops
<cybersyn>sorry