IRC channel logs

2021-01-17.log

back to list of logs

<rlb>rekado: also https://www.gnu.org/software/guile/docs/docs-2.2/guile-ref/SRFI_002d71.html
<apteryx>is it possible to use apply on macros?
<RhodiumToad>obviously not
<apteryx>So to compose macros one is forced to use macros, corrects?
<RhodiumToad>yes
<apteryx>there's this in srfi-64: (define (%test-match-any . pred-list) which is what I need, but it's not public
<apteryx>instead it is exposed as a macro like: (test-match-any pred ...)
<apteryx>I have my preds as a dynamically computed list
<RhodiumToad>computed at run time?
<apteryx>yes
<apteryx>it's the custom scheme srfi 64 test runner used in Guix; I'm trying to add a --select / --exclude arguments to allow filtering on individual test cases: https://paste.debian.net/1181459/
<apteryx>the part to fix is this line: (test-specifier (apply test-match-all test-specifiers))
*RhodiumToad shrugs
<apteryx>thanks anyway. Bed time here :-)
<apteryx>I tested this cheat just for fun: (define %test-match-all (@@ (srfi srfi-64) %test-match-all)); works.
<apteryx>good night!
***apteryx is now known as Guest14637
***apteryx_ is now known as apteryx
***rekado_ is now known as rekado
<rekado>apteryx: can’t we already restrict the tests to run with “make check TESTS=only-this”?
<rekado>rlb: yes, I used SRFI 71 and SRFI 11 before.
<rekado>but compose is nice and short
<leoprikler>rekado: that only limits to files afaik
<sneek>leoprikler, you have 1 message!
<sneek>leoprikler, raghavgururajan says: I have remove recursive for tg_owt in v13. :-)
<leoprikler>evil sneek, that's the wrong channel 😡️
<apteryx>rekado: not at the finer grain level of test cases (you can only select individual test files)
<apteryx>so if you are interested in a single test case in packages.scm, you can only run 'make check TESTS=tests/packages.scm' (or copy paste stuff at the REPL).
<apteryx>(I mean, with the above make check command, *all* the test cases of packages.scm get run, which takes quite some time).
<apteryx>rekado: moving conversation to #guix as we're new off topic :-)
<Rovanion>How do I join two lists? Just attach the second to the end of the first.
<Rovanion>Like Clojure's concat: https://clojuredocs.org/clojure.core/concat
<rekado>Rovanion: append
<Rovanion>Thank you!
***amiloradovsky1 is now known as amiloradovsky
<rlb>civodul: maybe ok to cherry-pick the symbol hashing fixes to stable-2.2 if it's fairly easy, so they'll be there if we end up making another release?
<rlb>e.g. 8b3cad618314f02ad3921fa104f17ca0f721dfcb and perhaps your couple of follow-on commits with tests.
<rlb>civodul: oh, and I'm also fine leaving 2.2 alone wrt anything non-trivial if we'd prefer. Obviously more work/risk whenever we try to handle both branches.
<civodul>rlb: sure, it doesn't hurt to cherry-pick fixes to stable-2.2
<rlb>OK, thanks -- I might backport some of the changes I just pushed to 3.0 too. And I was goingg under the assumption that the symbol hashing is ok for a Z release under the bugfix category.
<civodul>yeah
<rlb>Oh, and I was also trying to figure out when I should post patches to guile-devel. i.e. I had been intending to do that more, but during the push I was reminded that there's a commits list, so maybe that's often sufficient?
<rlb>I mean of course I'll still post patches for review when that's appropriate, but perhaps not things like simple doc fixes, etc.