IRC channel logs

2021-01-14.log

back to list of logs

<rlb>dsmith-work: I've wondered exactly the same thing, but haven't had a chance to investigate -- hopefully we'll be able to reproduce this and find out...
<rlb>wingo: This reproduces the crash in short order here: while ./check-guile asyncs.test; do sleep 0.1; don
<rlb>s/don/done/
<rlb>on v3.0.5
<rlb>i.e.
<rlb>ERROR: asyncs.test: preemption via sigprof - arguments: ((wrong-type-arg #f "Wrong type (expecting ~A): ~S" ("resumable continuation" #<vm-continuation 7f61fa1bbd20>) (#<vm-continuation 7f61fa1bbd20>)))
<rlb>
<rlb>usually in ~5 iterations
<RhodiumToad>the ERROR: blah - arguments: ((...)) thing comes from the test suite harness
<RhodiumToad>it catches all exceptions and reports unhandled ones that way
<RhodiumToad>(making no attempt to format the error)
***wxie1 is now known as wxie
<wingo>rlb: interesting, thanks for the report!
<tohoyn>sneek: botsnack
<sneek>tohoyn, you have 2 messages!
<sneek>tohoyn, daviid says: I pushed a series of (very important) patches, devel branch, so g-golf doesn't depend on libgdk-3 anymore (with these changes, you may prepare and remove the configure.ac dependency entry for gtk+-3.0 on the debian package def) - please pull and tell me if everything is ok ...
<sneek>tohoyn, daviid says: the <gdk-event> class is defined (then redefined 'on the fly') - Gdk 3.0 only, in Gdk 3.0, GdkEvent is not a class - with virtual slots and accessors for all gdk-event-get-* methods, then these additinak ones: keyname, x, y, root-x and root-y, with their accessors, !x, !y ... when it applies (that is if the event diefines the getter, otherwise, g-golf raises an exception)
<sneek>:)
<apfel>hi there, with-output-to-file i try to use it with fork and exec, similar to what somebody would do in C using dup(). https://pastebin.com/hHhWuY3N - but it does not work, at least the way i am doing it. Any ideas what i am doing wrong?
<leoprikler>Guile Syntax Gods, how do I define (define <prefix>-<common-part> "<other-prefix>-<common-part>") as a syntax rule/case?
<civodul>leoprikler: you don't!
<civodul>any other questions?
<civodul>:-)
<leoprikler>but… why not?
<civodul>it's "unhygienic"
<civodul>meaning that it introduces identifiers that do not appear in the source
<civodul>so you cannot do it with syntax-rules
<civodul>but you can do it with syntax-case
<civodul>you have to use the evil datum->syntax to do that
<leoprikler>okay, I think I got it
<leoprikler>having defined first and second as datum->syntax, I still need #`(define #,first #,second) though
<leoprikler>Is there a more beautiful way of writing this?
<civodul>not really
<civodul>you could use 'with-syntax' to avoid #,
<civodul>but that's not really "beautiful" either
<leoprikler>fair enough, with-syntax would break my careful indentation
<dsmith-work>UGT Greetings, Guilers
<leoprikler>good afternoon dsmith-work
<dsmith-work>RhodiumToad: Hrm. Ok.
<taw10>leoprikler: here is my solution to a very similar problem: https://git.bitwiz.me.uk/nanolight.git/commit/?id=ec502e06c5a0d6df91ee9b44f3694a9a5ecd0643 - It "works", except that Guile mangles the names of top-level bindings introduced by macros
<taw10>(... where the macro is provided by a module, that is. See https://www.gnu.org/software/guile/manual/html_node/Hygiene-and-the-Top_002dLevel.html)
<leoprikler>I don't think that's going to be an issue here. I only use this syntax locally to save some typing.
<apfel>ok, dup2 is available, i can work with that
<tohoyn>daviid: G-Golf fails to build. see https://paste.debian.net/1181136/.
<rlb>wingo: certainly - once we figure that out, 3.0.5 should be able to migrate from unstable to testing in debian.
***Guest364` is now known as daviid
<daviid>tohoyn: hum, could you run a 'git clean -dxf' in the source tree, and also clear your .cache/guile/ccache/2.2... of any g-golf related entry, then ./autogen.sh, ./configure ...
<tohoyn>daviid: same result
<tohoyn>daviid: I use "./configure --prefix=/usr --with-guile-site=yes"
<tohoyn>daviid: I also had to change GUILE_PROGS([2.0.14]) to GUILE_PROGS([2.2]) in configure.ac
<daviid>tohoyn: you shouldn't make that last change, and it is anyway irrelevant to the problem, which i have to think about, will ping when i have some solution, tx
<daviid>sneek: later tell tohoyn I pushed a fix, please pull, clean, and try again, let me know ...
<sneek>Got it.