IRC channel logs

2020-10-16.log

back to list of logs

***catonano_ is now known as catonano
<apteryx>wingo: it's not news anymore, but just wanted to say that the baseline compiler helps a ton in keeping the Guix sources workable; thank you!
***sneek_ is now known as sneek
<spk121>hello guile
<civodul>Hello Guilers!
<civodul>wingo: interesting review of the "binary security" paper!
<wleslie>ooh, a new wingolog.org post, about object capabilities in wasm
<wleslie>oh right, I think I dismantled this paper somewhere too
<wleslie>I boiled it down to "I can also express this vector using javascript modules"
<lloda>what causes guile to build with UNKNOWN version :-/
***jonsger1 is now known as jonsger
<lloda>what's the fix for this to work on guile-3
<lloda> https://github.com/davexunit/guile-zlib/blob/master/Makefile.am
<lloda>not that it doesn't work, but it installs in the wrong place
<lloda>davexunit: oh
<lloda>i miss a call-with-input-bytevector :-/
<RhodiumToad>then make one?
<lloda>indeed
<civodul>lloda: note that there's another guile-zlib, now used by Guix
<civodul>and the plan is to absorb davexunit's :-)
<davexunit>oh hi
<civodul> https://notabug.org/guile-zlib/guile-zlib
<davexunit>I wrote that one so long ago I forgot I even did it
<civodul>heheh
<davexunit>when I barely knew anything about guile
<lloda>thx both
<civodul>lloda: if you'd like to copy the bits from davexunit's guile-zlib to the other guile-zlib, that'd be welcome
<civodul>we were planning to do that
<davexunit>what bits?
<civodul>the low-level "compress" API
<civodul>the other guile-zlib only has the high-level gzip API
<davexunit>ah okay
<civodul>davexunit: i should say: WDYT? :-)
<davexunit>I haven't actually used this library in years, please take anything that's useful.
<civodul>heh awesome
<civodul>i was shamelessly planning to do just that :-)
<davexunit>I will update the github project description to point to the new lib
<davexunit>hey, it's free software
<civodul>yup
<lloda>civodul: your version has the stream functions so it's closer to what i wanted
<lloda>i'll see if i can send a patch later
<davexunit>I forgot why I ended up wrapping zlib... it was 8 years ago, though.
<civodul>we're a bunch of old-timers by now!
<dsmith-work>Happy Friday, Guilers!!
<civodul>hey dsmith-work, happy Friday!
<dsmith-work>Yes!
<lloda>civodul: https://notabug.org/guile-zlib/guile-zlib/pulls/1/commits
<lloda>didn't merge so much as copy the relevant bits from davexunit's repo, since i'd would have had to delete almost everything. I hope it's ok
<lloda>i'd/i
<civodul>lloda: excellent, thanks!
<civodul>Mathieu or myself will take a look
<lloda>np thank you both
<civodul>and we can prolly add you and davexunit there
<davexunit>civodul: no need to add me at this time. thanks, though.
<davexunit>one bit of feedback for that test: I would avoid randomized data in a test suite.
<civodul>yeah, or print the seed
<lloda>fixed seed, yeah
<lloda>fair
<lloda>it's the same as for the other test tho
<davexunit>oh okay so there's precedent
<davexunit>fair enough
<civodul>oops :-)
<zzappie>Hello guile!
<zzappie>I'm having problems whith creating http-post request... No mater what I do I always get the 400 bad request error even though I cheched the http request whith nc and it seems fine.
<zzappie>Its application/json request and I've tried making requests to httpbin.org/post with same result. Don't even know what to do next. Has anyone encountered something like this?
<zzappie>I guess it probably has something to do with tls
<dsmith-work>zzappie: Wireshark it and see what looks funny. Compare with something else that works there.
<dsmith-work>zzappie: By "nc" did you just check connectivity? Or did you acntually make an http post?
<zzappie>dsmith-work: I ran 'nc -l -p 8080' and made request to localhost:8080 to see whether all headers and body of the request look fine
<dsmith-work>zzappie: Well, something is wrong somewhere. Do you have some other app or something that *does* work that you can compare with?
<dsmith-work>Like a working example in some other language?
<dsmith-work>zzappie: So your immediate goal is find out something more specific that "bad request"...
<zzappie>dsmith-work: curl :)
<dsmith-work>yes indeed
<libfud>reason #84023823452085 why managed languages are nicer: you don't get bizarre, inexplicable segfaults from destructors when your build scripts don't properly rebuild/relink a module's objects
<rekado>84023823452085 looks like an overflowed number. That’s another reason why Guile is nicer ;)
<libfud>rekado: I'm not sure if it is
<libfud>maybe it's a bigint :)
<libfud>(< 84023823452085 (expt 2 63)) --> #t
<dsmith-work>scheme@(guile-user)> (number->string 84023823452085 16)
<dsmith-work>$1 = "4c6b522647b5"
<libfud>dsmith-work: now format that with uppercase letters with in 8 character segments with leading zeros
<libfud>working in C++ is such a PITA
<libfud>I can never figure out the signature for functions or closures as parameters so I always wind up doing template<TypeName Fn1> foo(Fn1 bar)
<izh_>how to use http-request to read body from a URL that redirects?, e.g. "https://qa.debian.org/cgi-bin/popcon-data?packages=bash"
<izh_>(http-request "https://qa.debian.org/cgi-bin/popcon-data?packages=bash") returns just empty #vu8() instead of expected json
<dsmith-work>scheme@(guile-user)> (format #f "~17,'0,'_,8:x" 84023823452085)
<dsmith-work>$14 = "00004c6b_522647b5"
<dsmith-work>
<dsmith-work>uppcase
<dsmith-work>scheme@(guile-user)> (format #f "~:@(~17,'0,'_,8:x~)" 84023823452085)
<dsmith-work>$15 = "00004C6B_522647B5"
<libfud>I was being flippant but that's actually pretty illustrative of formatting so thank you
<libfud>uppercase hex always looks a lot better to me
<libfud>why does the upcase version need a the ~ sigil after x?
<libfud>nvm
<libfud>dsmith-work: in my instance of guile (2.0.14... wait, why is it 2.0.14?) the second is still lowercase
<dsmith-work>The ~:@( ~) uppercases stuff in between. Wack. But probably from CL.
<libfud>which version of guile are you using?
<dsmith-work>3.0.4
<libfud>which distro are you using?
<dsmith-work>Debian Buster, but guile built from source tarball.
<libfud>yeah I don't see it in fedora
<libfud>when did 3.0 come out?
<dsmith-work>June 24, 2020 for 3.0.4
<dsmith-work> https://lists.gnu.org/archive/html/guile-sources/2020-06/index.html
<dsmith-work>Jan 16 for 3.0.0
<dsmith-work>Ya, I like 0xFF: small x, uppercase hex
<dsmith-work>I really like how Rust (and others) allow _ in numbers.
<dsmith-work>Like 0xFFF_FFFF
<libfud>yeah, that's something I wish more languages had
<dsmith-work>Kind of like commas
<dsmith-work>Make it *much* nicer to read large numbers..
<libfud>your example works in 3.0.4 but not 2.0.14 or 2.2.whatever-it-is
<libfud>I didn't test prior versions of 3 but I'd hazard a guess that it wouldn't change the result
<dsmith-work>Hmm. Unfortunaely, it doesn't add separators in the padding:
<dsmith-work>scheme@(guile-user)> (format #f "~:@(~19,'0,'_,4:x~)" 84023823452085)
<dsmith-work>$18 = "000004C6B_5226_47B5"
<dsmith-work>Hah! CL does the same. (sbcl anyway)
<libfud>the last time I actually worked extensively with Hex as output (and inputs to some degree) was a MOS6502 emulator I made while trying to make a NES emulator
<libfud>grouping it is essential to reading it
<dsmith-work>Ahh. the 6502
<dsmith-work>First thing I did on my C64 was make a disassembler.
<libfud>It was fun, I liked that I could understand everything it did (after learning about it's quirky behaviors that don't match the spec)
<stis>o/