IRC channel logs

2020-09-18.log

back to list of logs

***catonano_ is now known as catonano
<nalaginrut>morning guilers~
<nalaginrut>I see, if I want to install guile with readline, I need to install readline first, then install guile, it'll be detected. However, it'll compile locally
<nalaginrut>btw, guile3 need readline7, in case someone care
<nalaginrut>oh, forget about it, it's wrong answer. Installing readline7 can pass guile3 compiling, but it still complains no readline
<wleslie>did ./configure pick it up?
<wleslie>I mean: did you re-run configure, and did it detect readline?
<str1ngs>ArneBab: nice.
<str1ngs>ArneBab: I've been meaning to see if I could use wisp as a kinda DSL for nomad's mini buffer.
<tohoyn>sneek, botsnack
<sneek>:)
<ArneBab>str1ngs: that would be cool!
<ArneBab>str1ngs: a problem I can see for that would be, however, that wisp terminates with two newlines. What you could do is to define return as ending the input and shift-return as continuing it. Then you would have something like a shell with full scheme semantics that doesn’t need an opening or closing parenthesis.
<mwette>sneek: later tell matijja, instead of parameter use (define *x* (let ((xval '())) (case-lambda (() xval) ((x) (set! xval x)))))
<mwette>
<sneek>Okay.
<ArneBab>str1ngs: all you need to read wisp code is to have language/wisp.scm and language/wisp/spec.scm in your load path, similar to here: https://hg.sr.ht/~arnebab/wispserve/browse/language?rev=4541f36df0b0
***roptat_ is now known as roptat
<str1ngs>ArneBab: I will play with it some time. but would be cool to do something like. find-file "~/.nomad." right from the minibuffer. with completions
<ArneBab>that would be pretty cool, yes!
<str1ngs>or load-uri "http://gnu.org"
<str1ngs>right now optional arguments are handled like emacs with minibuffer prompts
<ArneBab>that should actually work, just pass the minibuffer-content to (wisp-scheme-read-string STRING) or as port to (wisp-scheme-read-all PORT)
<ArneBab>(import (only (language wisp) wisp-scheme-read-string))
<ArneBab>I have not yet tested that embedded in another application, though
<ArneBab>readline from Guile actually works on that (because the procedures are all the same)
<ArneBab>(so completion matches)
<str1ngs>nice, would make the minibuffer more flexible I think. with less abstraction. also I wouldn't mind having some nomad extensions in wisp just as an example of alternate language.
<ArneBab>please tell me when you test this (and how it goes)!
*ArneBab needs to be AFK; taking kid to sport
<str1ngs>will do, good luck at sport
<ArneBab>thank you — I’ll tell her (I only walk there and back)
<ArneBab>(still need to work)
<matijja>Hello Guilers!
<sneek>Welcome back matijja, you have 1 message!
<sneek>matijja, mwette says: instead of parameter use (define *x* (let ((xval '())) (case-lambda (() xval) ((x) (set! xval x)))))
<matijja>mwette: Nice!
<manumanumanu>Ahoy!
<matijja>o/
***rekado_ is now known as rekado