IRC channel logs

2020-09-07.log

back to list of logs

<mwette>.
<RhodiumToad>moo
***terpri_ is now known as terpri
***apteryx is now known as Guest64102
***apteryx_ is now known as apteryx
<simendsjo>Is https://www.gnu.org/software/guile/libraries/ currently the best place to find libraries for guile? I asked around on the mailing list some time ago, which caused some rants on the topic, but didn't conclude on any better list even though this list is probably lacking a lot.
<dsmith>simendsjo: There is also this list:
<dsmith>sneek: guile-software?
<sneek>Its been said that guile-software is http://sph.mn/foreign/guile-software.html
<simendsjo>sneek: Thanks, didn't know about that one. Looks like there are projects there not added to guix too.
<civodul>simendsjo: the list of gnu.org/s/guile/libraries is built from Guix packages, so at least you know it's usable and somewhat "lively"
<civodul>the downside is that well, anything not in Guix is missing :-)
<matijja>Hello Guilers!
<RhodiumToad>good evening
<matijja>I have problem with this example: http://paste.debian.net/1162918/
<matijja>Why I can't close only output port?
<RhodiumToad>the interface for bidirectional pipes is a bit ... broken
<matijja>hmm, is there any workaround?
<RhodiumToad>yeah, sec
<RhodiumToad>I think you basically have to stick to using open-process and handle the read and write ports separately
<RhodiumToad>open-input-output-pipe hides the read and write ports inside a closure, so there's no simple way to access them
<rlb>Debian's had some additional failures in test-out-of-memory, now on ppc64el, even with -fno-stack-protector: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=966300 (that links to a bug-guile bug from 2.2.2, i.e. this test has long-standing issues). Since we've already commented out most of the test, I'm thinking about just disabling it for now in Debian, but of course happy to re-enable it, or help with testing if/when anyone has
<rlb>time to pursue it.
<rlb>"already commented out": https://salsa.debian.org/rlb/deb-guile/-/blob/deb/guile-3.0/v/3.0.4-1/test-suite/standalone/test-out-of-memory#L63-83
<matijja>RhodiumToad: I did it. Thank you. (http://paste.debian.net/1162922/)
<rlb>New(?) numbers.test failure on i386: https://bugs.debian.org/968403 I'll forward it in a minute.
<hendursaga>Is there a non-blocking scm_shell function or would I have to run that under a thread? I'm rather new to C.
<rlb>iirc that's just blocking? but you could use also open-pipe.
<rlb>or open-pipe*
<matijja>Does Guiel has any `mkfifo' function? Or I can just `(system "mkfifo /tmp/my-fifo")`?
<matijja>*Guile
<hendursaga>rlb: Guile's open-pipe? I'm trying to extend a C program to be scriptable in Guile, and I want the user to have a REPL.
<RhodiumToad>matijja: mknod can make fifos.
<matijja>RhodiumToad: Thanks.
<hendursaga>Oh! Perhaps I could run a REPL server? Like how Geiser works?
<rlb>hendursaga: ignore me -- you clearly said scm_shell, but I heard scm_system :)
<matijja>hendursaga: Did you check that? (info "(guile) REPL Servers")
<matijja>RhodiumToad: Is there any reason, why (mknod "/tmp/p" 'pipe #o666 0) makes rw-r--r-- permissions. But (chmod "/tmp/p" #o666) do the trick?
<RhodiumToad>umask
<RhodiumToad>mknod, like all file creation calls, respects the current process umask, while chmod does not since it's supposed to set exactly the mode specified
<matijja>Ah ok. Thanks.
<wingo>o/
<hendursaga>matijja: It appears I can use spawn-server..
<manumanumanu>Ahoy!