IRC channel logs

2020-09-04.log

back to list of logs

<civodul>g0d_shatter: yes
<civodul>that's for the next GDB release
<g0d_shatter>civodul: right, GDB 10, I just wanted to make sure that the patch makes allows one to use the latest guile version and not just guile-2.2, which is what was described in the patch by Ludovic.
<g0d_shatter>apparently a patch was submitted today on the blocking bug for GDB 10 so that should get out in the next month
<daviid>str1ngs: hello, no sure i understood, but the version in configure.ac now is 0.1.0, i'm happy to bump it to 0.2.0 if that helps?
<str1ngs>daviid: no need, as long as you are sticking with 0.1.0. sorry for the noise the mistake was on my end when I initially submitted the guix package.
<g0d_shatter>I'm having problems compiling older versions of gdb with guile support, for whatever reason "sudo make install" is failing to install the required guile files to their proper system location, and even moving them there by hand doesn't seem to help
<g0d_shatter>is this a problem that sounds familiar at all to anyone?
<str1ngs>hello g0d_shatter what error do you get when you do sudo make install?
<str1ngs>g0d_shatter: ahh I read your question better. are you using --prefix=/usr assuming you are on linux.
<g0d_shatter>str1ngs I have used that switch and not used it, both times the libraries aren't copied to their proper locations
<str1ngs>do you have more then one version of guile installed? Debian with use alternatives which could confuse things
<str1ngs>try using ./configure GUILE=/full/path/to/guile --prefix=/usr
<str1ngs>also check configure for gdb does it actually find guile?
<str1ngs>assuming you are having issue with the gdb make install.
<g0d_shatter>str1ngs I don't, I've been bitten by the "multiple versions installed" issue before
<str1ngs>gotcha I guess you are on debian based system?
<g0d_shatter>str1ngs It does *find* guile, because I don't think it would compile if it didn't
<g0d_shatter>or at least it hasen't before
<g0d_shatter>I am
<str1ngs>which gdb, it might compile the question is does it find guile support
<str1ngs>grep guile config.log might give a clue.
<g0d_shatter>debian stabel
<str1ngs>which toy is that buster right?
<g0d_shatter>gdb 8.2.1
<g0d_shatter>yep
<str1ngs>do a configure and check config.log
<str1ngs>sometimes configure will give summary as well.
<g0d_shatter>str1ngs thank you for taking the time to help out, I'm going to retry the whole thing from configure to make again
<g0d_shatter>the flags i'm using are ../configure --prefix=/usr --with-system-readline --with-guile
<str1ngs>I treat guix like a gnu mirror. guix build gdb@8.2.1 -S
<str1ngs> /gnu/store/w3cg73az1kly0qj8kxy9l8fw484ljzpm-gdb-8.2.1.tar.xz
<g0d_shatter>I honestly have no experience with guix other than reading the code for the elf parser, which I have heartily copied from :)
<johnjay>g0d_shatter: elf parser? what is that
<g0d_shatter>however looking at the gdb docs, at the configure options, I see one called "--with-relocated-sources=dir" which I'm wondering if I should pass since I'm building this in a directory off of my home
<str1ngs>g0d_shatter: I'm not seeing any option to build gdb with guile support. or do you build guile with gdb support
<g0d_shatter>johnjay https://git.savannah.gnu.org/cgit/guix.git/tree/guix/elf.scm
<g0d_shatter>str1ngs no you build GDB with guile support, hold on I'll link you the doc showing it
<g0d_shatter>str1ngs https://sourceware.org/gdb/current/onlinedocs/gdb/Configure-Options.html
<g0d_shatter>control-f "guile" will take you down to it, its the 8th flag up from the bottom of the page
<dsmith>g0d_shatter: Hmm. You might need to run ldconfig (as root) after installing guile. Not saying that's your issue, but it might be.
<johnjay>g0d_shatter: interesting. why does it say it wasn't needed anymore and what happened to it?
<str1ngs>g0d_shatter: got it. it should also autodetect
<g0d_shatter>dsmith: if I'm installing guile via debian's apt, does that matter?
<g0d_shatter>dsmith so far I use apt to install all of the necessary dependencies, grab the appropriate source and then try to compile it in a sub directory of home and just "sudo make install" after "make". gdb compiles, with partial guile support, and installs, but doesn't copy the guile libraries over to the proper system location
<g0d_shatter>johnjay: I'm guessing you're referring to the comment in the elf parser file? I don't know, its not the only elf related file in the guix tree, I believe
<johnjay>is guix basically apt/melpa/cpan but for guile?
<str1ngs>g0d_shatter: what is your guile --version?
<str1ngs>g0d_shatter: I got it to buile guile support but only guile-2.0
<g0d_shatter>str1ngs yep only 2.0 until the next release of gdb, what was the recipe you used to build it with guile support? was it on buster?
<str1ngs>g0d_shatter: just make sure you have guile-2.0 and guile-2.0-dev installed
<str1ngs>maybe even guile-2.0-libs
<g0d_shatter>str1ngs huh, I do have all of those installed
<g0d_shatter>hoping that ldconfig trick dsmith mentioned does the trick we'll see, I'm compiling it now
<str1ngs>g0d_shatter: after make . do make install DESTDIR="$PWD/temp" then you can see the tree with. find ./temp
<g0d_shatter>and its compiled the guile libs so far, lets see if it puts them where they're supposed to go
<str1ngs>you are installing to /usr or somewhere else?
<g0d_shatter>str1ngs will do!
<g0d_shatter>yeah, --prefix=/usr
<str1ngs>also gdb does not install to standard paths. it does not use site path
<str1ngs>so installing to /usr probably won't help you
<str1ngs>I wold just use /usr/local or $HOME/local
<str1ngs>you may need to set GUILE_LOAD_PATH
<str1ngs>it *does* bytecompile sorry
<str1ngs>so you'll want GUILD_LOAD_COMPILED_PATH too
<g0d_shatter>str1ngs so when I tried to build gdb with only the --with-guile flag, it installed to /usr/local but still didn't collect the guile files to /usr/share/gdb/guile/gdb
<str1ngs>(gdb) guile (+ 1 1)
<str1ngs>2
<str1ngs>awww yeah
<g0d_shatter>nice
<str1ngs>g0d_shatter: just have guile-2.2 and guile-2.2-devel installed and configure with --with-guile. make install start gdb and try guile (+ 1 1)
<str1ngs>don't bother with guile-2.0
<str1ngs>trow that ole thing out! :P
<g0d_shatter>str1ngs is this on Buster?!?
<str1ngs>I'm on focal 20.04
<g0d_shatter>I don't know what that is
<str1ngs>think of it as bullseye
<str1ngs>but the toys never get put away :P
<str1ngs>g0d_shatter: it's ubuntu 20.04 LTS
<g0d_shatter>I see
<g0d_shatter>str1ngs: what version of GDB are you using?
<str1ngs>I tested with gdb-8.2.1
<g0d_shatter>hmmmmmm
<g0d_shatter>well lets give it a shot
<str1ngs>from what I gather gdb only needs libguile and it loads what it needs based on the --prefix. so no GUILE_LOAD_PATH required etc.
<g0d_shatter>well I just purged guile-2.0 and installed guile-2.2 via apt, as well as guile-2.2-dev and guile-2.2-libs so we'll see if this actually works
<str1ngs>g0d_shatter: I was kidding about guile-2.0 but if you don't actually need it best to remove it.
<str1ngs>some autotools get fancy with getting guile versions. you can though somtimes use ./configure GUILE=/usr/bin/guile-2.2 to un-confuse it
<g0d_shatter>str1ngs kidding how?
<str1ngs>g0d_shatter: or when I said throw that ole thing out :P
<g0d_shatter>I mean I've had problems with gdb finding the correct version of guile when building it for a couple years now
<g0d_shatter>and the only times I've had it correctly build is with only one guile installed
<str1ngs>if you see gdb/configure.ac it gets all fancy
<dsmith>g0d_shatter: IF you have installed guile and all by packages, no, you don't need to run ldconfig.
<g0d_shatter>dsmith: gotcha, thank you
<dsmith>There is a cache used by the shared object loader, and ldconfig updates that cache. If you copy a lib*.so to some dir in your lib path, and it's not being found, running ldconfig will let it be found.
<g0d_shatter>dsmith: ahhh
<g0d_shatter>dsmtih: thank you
<g0d_shatter>str1ngs: well its not working on this install, I get the same "cannot find a usable guile from guile-2.0" error on executing make
<g0d_shatter>str1ngs: so at this point I'm just going to be trying to build the GDB snapshot on an appropriate system I guess
<str1ngs>g0d_shatter: what does this output guile -c "(display (version)) (newline)"; pkg-config --libs guile-2.0
<g0d_shatter>str1ngs: 2.2.4 on the first command and no libs found on the second (since I had deleted all traces of any guile-2.0 pacakges)
<str1ngs>g0d_shatter: apt show guile-2.2-dev
<g0d_shatter>they're all gone, I've deleted them from the system, it won't compile with guile 2.2. I don't know how you got it to work on focal but it isn't working here since this version of GDB isn't patched to run with 2.2
<str1ngs>ffs /lib/x86_64-linux-gnu/libguile-2.0.so.22
<str1ngs>what that's 2.2
<str1ngs>I think
<str1ngs>g0d_shatter: I'm sorry its using guile-2.0-libs
<str1ngs>so apt install guile-2.0-dev
<str1ngs>you need that package for gdb
<g0d_shatter>yeah, I've danced this dance many many times, I gave it a shot just in case but I have to install guile-2.0 only for the next month or so
<str1ngs>g0d_shatter: sorry for the confusion it only using so it will link to that guile interpreter irrelevant
<str1ngs>using libs*
<g0d_shatter>no worries
<str1ngs>so I have a good idea of what you need should only need guile-2.0-dev
<g0d_shatter>it'd be really nice to get it to work on this vm since its got a different program it took all night to correctly compile and setup and I'd like to use them in a pipeline type situation
<g0d_shatter>but if that has to wait, then that has to wait
<str1ngs>then test with pkg-config --libs guile-2.0
<str1ngs>-lguile-2.0 -lgc
<str1ngs>should output something like that
<g0d_shatter>going to duck out for a little while, if I still need some help I'll try this tomorrow or later tonight, thank you all for your help, I really appreicate it
<daviid>str1ngs: np, i'll stick to 0.1.0 then
<str1ngs>sneek: later tell daviid. g-golf and nomad running on my pinephone https://bufio.org/images/2020-09-03-220022.png
<sneek>Will do.
<mwette>g0d_shatter: does /usr/bin/ contain guile-2.2 but not guild-2.2? If so, that may be a problem. I had issues on debian derived OS before on that.
<dsmith-work>Happy Friday, Guilers!!
***dddddd__ is now known as dddddd