IRC channel logs

2020-09-01.log

back to list of logs

***jonsger1 is now known as jonsger
<g0d_shatter>Hi all, I was curious if anyone can tell me before I try to build it if this patch will allow building gdb against guile-3.0 as well as guil-2.2
<g0d_shatter> https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=68cf161c24b096608bf4a1b97b489cc7277bffc0
***apteryx is now known as Guest19503
***apteryx_ is now known as apteryx
<daviid>cd
<wingo>good morning :)
<dsmith-work>Morning Greetings, Guilers
<lloda>my question about handling C-c yesterday was about those stretches of code where I cannot C-c to interrupt
<lloda>i want a way to tell Guile that it's ok to interrupt
<lloda>i'm ok with the default handler, I don't need a custom one, I just want it to be called, or the signal to be raised, or w/e is not happening over those stretches of program
<mwette>Based on comment yesterday, it sounds like if your program gets stuck in an infinite loop in a C function executed by Guile, you can't C-C out of it.
<lloda>yes. In my case it's a Scheme loop with some C functions inside. It isn't stuck and I still cannot C-c.
<lloda>if let's say 1% of the time is spent running Scheme and 99% is spent running C, I still want to be able to interrupt it
<lloda>if that matters
<dsmith-work>Maybe there is something you can insert into your loop every so often that lets the hander run.
<lloda>yes
<lloda>that's what i'm looking for
<dsmith-work>lloda: maybe scm_async_tick() ?
<lloda>is there a scheme version of that?
<lloda>I am not running pure C
<lloda>I rather keep the C I have independent of Guile
<dsmith-work>lloda: https://www.gnu.org/software/guile/manual/html_node/Asynchronous-Signals.html
<dsmith-work>SCM_TICK is just: #define SCM_TICK scm_async_tick ()
<dsmith-work>
<dsmith-work>If you are in scheme, there is no need, apparently. Seem to be for long stretches of C code that do not call into libguile.
<lloda>that's what I don't get
<lloda>there is Scheme code running and I cannot interrupt it
<lloda>it isn't pure C code
<lloda>I will try SCM_TICK tho cause I need a solution
<lloda>thx dsmith-work
<dsmith-work>Though scm_async_tick just returns if SCM_I_CURRENT_THREAD->block_asyncs is true.
<dsmith-work>lloda: Maybe your code is running with async blocked somehow?
<dsmith-work>lloda: I'm curious to see if that helps.
<lloda>i do use openmp in the C
<lloda>not sure what else could be
<mwette>lloda: maybe look at vm-trace-level in the manual
<mwette>OpenMP is going to be running threads, so that might complicate things. Is your guile/c data mt-safe?
<lloda>yes
<lloda>get input / compute stuff / put output
<lloda>self contained functions
<lloda>thx for the pointer
<stis>Hi guilers!
<dsmith-work>hej Hej HEJ
***amiloradovsky1 is now known as amiloradovsky