IRC channel logs

2020-08-07.log

back to list of logs

***schaeffer_ is now known as schaeffer
<daviid>.
<sneek>Welcome back daviid, you have 1 message!
<sneek>daviid, str1ngs says: both <webkit-navigation-policy-decision> and <webkit-response-policy-decision> work now. without using change-class. I only test 'decide-policy signal since that's the only signal I know of right now that does this.
<daviid>str1ngs: ok, perfect - it will work for any signal that sublcasses one or more of its arguments
<pkill9>what's the character code for open and close parentheses?
<pkill9>codes*
<daviid>pkill9: that is a quiz for the repl :)
<pkill9>nevermind, don't need it
<pkill9>i forgot about string-replace-substring
<pkill9>hmm
<pkill9>how do i replace "(" with "\("?
<pkill9>(string-replace-substring "(" "(" "\(") does nothing
<daviid>pkill9: prob need to escape the \
<daviid>"\\("
<pkill9>that returns "\\("
<daviid>yes, but write it to a port ...
<daviid>(display "\(\n") vs. (display "\\(\n")
<daviid>pkill9: 6.15.3 Backslash Escapes
<pkill9>i see, thanks
<daviid>wc!
<pkill9>wc?
<daviid>welcome
<pkill9>ah
<daviid>pkill9: and 6.6.3 Characters as well ..
<daviid>(char->integer #\() (char->integer #\)) to answer your previous quiz
<lloda>or you could use https://github.com/lloda/guile-raw-strings and not worry about escapes ^^
<dsmith-work>Happy Friday, Guilers!!
<a_v_p>Guilers! I'm thinking about a macro for my recent project (Metabash) that should look something like this: (M#! remote session "cat /etc/hosts" => local "sort" => local "grep 127.0.0.1")
<a_v_p>Is it possible to accomplish with syntax-rules/syntax-case, or I need something *more powerful*?
<dsmith-work>a_v_p: Have you looked at scsh ? ISTR that they had some maros for command lines. That was probably with lispy defmacro style macros though.
<dsmith-work>a_v_p: https://scsh.net/
<topoi>dsmith-work: The acknowledgements read tough though (https://scsh.bnet/docu/html/man.html)
<dsmith-work>Heh
<a_v_p>dsmith-work: Thanks! I think I saw some examples of macros from SCSH sources today... seems to need to dig deeper.
<dsmith-work>I think there have been at least two different efforts to port scsh to guile in the past. Not sure what the current status is.
***ftknox_ is now known as ftknox
<a_v_p>dsmith-work: Almost there: https://gist.github.com/artyom-poptsov/f1a3479522455b97cbbf30801d395f1e
<a_v_p>Unfortunately it does not match syntax like: (M#! remote session "ps aux" => local "grep guile")